Outdated topic

Outdated topic…fgfgfgfgfgfgfgfgfgfg

Hi @user14132,

Can you:

  1. Check that the nameservers below your DNS records in the Cloudflare Dashboard are martin and alla?
  2. Open the SSL/TLS → Edge Certificates page and post a screenshot of it.

There’s more info on the error here:

Thanks, at the bottom of that Edge Certificates page, what does the Universal SSL option say? “Enable Universal SSL” or “Disable Universal SSL”?

It says Enable because I have disabled it

Well, that’s why you’re getting the error. You haven’t purchased a different type of edge certificate to replace it so there’s no cert being served from Cloudflare’s Edge.

1 Like

Ok can you explain it. I’m using a origin server certificate. Why do i have to use the universal ssl too?
Also, now I get to 522 host error.

When you proxy your site through Cloudflare, there are two parts to the connection.

Visitor → Cloudflare → Origin

Your Origin Certificate secures the second part Cloudflare → Origin but your visitors will never see that. The edge certificate on Cloudflare is served for the Visitor → Cloudflare part.

522 indicates a server error:

Could You help me with my origin server problem, then?
It’s ubuntu server 20.04.03 LTS with apache2 . I can load the page with the ip on http. Nothing more.
I have been trying to get it to work all day. I have looked at 10 websites and 4-5 youtube videos but…still nothing

If you pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions, wait 5 minutes for it to take effect. Can you then see the site OK? You will get a certificate warning because of the origin cert but if you click through that, do you see it working normally?

1 Like

Now
"# This site can’t be reached
. took too long to respond.
Try:

That shows the actual error from your server now Cloudflare is not involved. You’ll need to resolve that before you unpause Cloudflare.

So I’m still struggling to make it work. If anyone wants to waste time helping me more to figure out what’s happening I would appreciate it. I have to fix the https - not working at all on ubuntu 20.04 apache2. Ask for configs and everything.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.