Our Wordpress Website Using Cloudflare is No Longer Showing Mobile Version on Mobiles

Our Wordpress website is Azam.info. Before we switched to full Cloudflare, it worked perfectly in the sense that a desktop ‘full’ version of the website would appear on desktop devices and a mobile version would appear on mobile devices.

The mobile version would show through a plugin called ‘WPtouch’.

Howeber, since setting up Cloudflare, the mobile version usually doesn’t show. People see the desktop version of the website on their mobile.

Sometimes we see a mobile version of the website on desktop.

We have meticulously set-up Cloudflare (free version) as per all the guidelines.

The SSL/TLS encryption mode is set to “Full”.

We have got the ‘WP Cloudflare Super Page Cache’ plugin installed.

The Page Rules we have set-up for this website within Cloudflare are as follows:

I’m not an expert, but it seems that Cloudflare is caching a desktop version of the site and then showing that to mobile users without allowing ‘WPtouch’ to show a mobile version?

Could you please guide me in terms of what we can do so that our mobile plugin continues to work and shows people a mobile version of the website when on mobile, and that a desktop version shows to desktop users?

Thanks a million. I’m grateful for your assistance.

Your page rule tells Cloudflare to “Cache Everything”. So it will. If a Desktop visitor hits the site, Cloudflare will cache that version of the page. If you need to cache by device, APO ($5/month on free plans, free on paid plans) does this.

3 Likes

Confirm, we released “Cache by device type” specifically to provide caching for WordPress sites using WPtouch and similar plugins.

3 Likes

Thank you for the helpful feedback.

Rather than purchasing the “Cache by device type” service, I have deleted the Edge Cache page cache completely from the Page Rules for this website. See second rules below. They are now as follows:

I have purged the website several times, both in Cloudflare and the Cloudflare Wordpress plugin.

I have waited a few hours since the cache was removed and purging the cache several times.

However, the website is still showing the desktop version even on mobiles. I have viewed the website by clearing the mobile browser cache and also in incognito mode etc., but it always shows in desktop view. It means our text is tiny and unreadable.

I have tested it many times using different browsers, mobile phones etc.

Before we were using Cloudflare, it would show the mobile version on mobile phones.

Could you please let us know what we can do?

Thank you.

It looks like you have some caching at the server as well. Cloudflare isn’t caching the page, so there seems to be some caching confusion on the site itself. Have you tried disabling caching at your site?

1 Like

Thank you for the helpful response.

I’ve carefully checked and we are not using any other caching service.

I’m wondering if Cloudflare is still caching the website because of some setting or other? These are our Cloudflare settings on our webhost (which is integrated with Cloudflare) and it is the same settings on our Cloudflare Wordpress plugin etc.:

The Page Rules we are using are in my post above.

Is there any specific settings we could change so that mobile users are once again presented with a mobile version of our website?

To recap, we have a Wordpress plugin that shows mobile users a mobile-friendly version of the site. This worked perfectly for many years before. However, since setting on full Cloudflare, mobile users no longer see a mobile version of the website. This means the mobile users can’t read the very small text they see when visiting our blog etc.

Thanks a million. I’m grateful for your assistance.

Really?

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.