Origin Unreachable 523. I have Exhausted all possible solutions on my own

I have been trying to get this to work for several days using a domain I purchased through google and setup through Cloudflare. The webpage is supposed to lead to a personal sever set up on an unraid server with a reverse proxy application NGINX manager. Everything I have tried through results on google and here do not work. No matter what I do, I get “Origin is unreachable Error code 523”.

  • I setup Cloudflare with my personal IP set in the DNS settings. I set a CNAME subdomain for overseerr. I created an Origin SSL certificate through Cloudflare and set it to strict.
  • I forwarded ports 80 and 443 to ports 1880 and 18443 with the IP of my unraid server of unraid server) within my router.
  • I installed NGINX docker and set network to Bridge. I then set it up with a user and password. I added my website as a host and added the origin SSL certificate to it

Originally, going to the web address for my site would strangely lead to the login page for one of my Reolink security cameras. I disabled UPNP within my router, and then it would only display the Cloudflare page with “Origin is unreachable Error code 523” These are things I have tried;

  • I have tried removing and reinstalling NGINX multiple times with deleting all files in appdata in between.
  • I have tried it on different network setting such as individual docker networks, and Br0(Where an individual IP was assigned, and I changed the IP for the port forwarding in the router respectively)
  • I have done various testing. I can ping my website successfully.
  • Running a traceroute ends at the Cloudflare servers
  • Scanning open ports for the website shows port 80 and 443 open.
  • Using Telnet, I am able to successfully ping ports 80 and 443 for my website
  • whois for my website says Cloudflare.
  • I have also tried setting up other subdomains for other dockers.
  • running a curl command in to see the IP for NGINX and overseer both returns my external IP indicating that they can both reach out to the internet.
  • I do not see anything strange in the logs for NGINX.
  • I have removed everything else within my network with an open 80 and 443 port.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.