Origin Server certificate, keys and CA .crt files

Is there any way to get the certificate, key and origin CA in file.crt? My Apache hosting use Plesk and it accept only that file extension.

I already followed the page for the origin configuration of Cloudflare but without having success.

In addition, after running the Diagnostic Center test I got these errors the SSL/TLS tab:
• Check if redirecting unencrypted HTTP traffic works → no_redirect_to_https
• Check the site for mixed content → response_non_200

Is there a way to fix these errors?
are they caused by lack of the right SSL/TLS certificates on my hosting and/or lack of communication between Cloudflare and my domain?

Welcome to the Cloudflare Community.

Files using the .crt extension contain the same data found in a .pem file. If you have a .pem file, you can rename it to end with .crt and it should work just fine.

If you click on the linked text, it will help you solve that issue. The redirect is more or less self-explanatory. Make sure you redirect all of your HTTP traffic to HTTPS and that will clear up. The Cloudflare documentation on Always Use HTTPS should prove useful if you need some more details.

Thanks for your welcome and for your kind reply @epic.network!

I tried to follow your suggestions but unfortunately I’ve got an error on Plesk after having uploaded the certificate with .crt extension: “Error: Invalid certificate format”.

I tried to to copy the certificate, the key and the origin CA on the field of the Plesk under : “New Certificate” → everything went well but when I test it with Diagnostic Center of Cloudflare I still get the same errors.

As you suggested me I also checked the options “Always Use HTTPS” and “Automatic HTTPS Rewrites” and both of them were already active.

I really don’t know where the problem is.

I don’t know what Plesk expects the file to contain, but they should normally consist of the key, followed by the leaf certificate, and then any intermediate certificates. I found a guide you can reference over at SUSE Linux that goes into more detail.

I did it again and I was able to upload them all on Plesk with success.

Once I tried the Diagnostic Test again, I just got the same errors:

I guess the problem is not due the certificate, Key and CA but I’m digging since days on this issue without good results…

Is there other thing I could check to get rid of this no_redirect_to_https?

Thank you for all the help you’re giving to me.

Do you get anything useful when clicking the Resolve Issue or Learn More buttons?

By clicking on “Resolve Issue” it reindex me on the homepage of my Cloudflare account while the Learn More button drive me to HTTP Status Codes page

I also try to set up the HSTS Preload option under SSL/TLS → Edge Certificates → Change HSTS Settings and there I started having trouble with the no_redirect_to_https.
I already got in touch with my hosting provider but from their side it’s everything working correctly so, I guess there’s some wrong setting on my Cloudflare

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.