origin,resnok

Hello,

I have a problem with my wordpress site and I can’t find a solution. On my home page, my cache is constantly emptying, and I get the following response in the header: Miss, origin,resnok

If I’ve read the documentation correctly, this corresponds to a code other than 200, so the page is not cached. But here the code received is 304, which corresponds to no modification. I don’t know if this behavior is normal, but the response time is longer when the cache is miss. How can I correct this?

In addition, the cache may display hit for 40 seconds and then miss again after a refresh: origin,resnok.

the site is https://www.asiasport.be

thank you

I got a MISS (cf-apo-via: origin,miss), then a HIT (cf-apo-via: tcache) for https://www.asiasport.be/

And then a MISS a bit later. Do you have any Page Rules or Cache Rules that are applying to your site?

Hello,

I have exactly the same behavior except that it says miss: origin,resnok.

I have 3 cache rules:
1- Cache Wp-content and wp-includes with forced browser and TTL edge of 6 months

(starts_with(http.request.full_uri, "/wp-content/")) or (starts_with(http.request.full_uri, "/wp-includes/css")) or (starts_with(http.request.full_uri, "/wp-includes/js")) or (starts_with(http.request.full_uri, "/wp-includes/images")) or (starts_with(http.request.full_uri, "/wp-includes/fonts")) or (starts_with(http.request.full_uri, "/wp-includes/blocks"))

2- Don’t cache Wplogin, cart, cookie, ect…

(http.request.full_uri contains "/wp-admin") or (http.request.full_uri contains "/wp-login.php") or (http.request.full_uri contains "/checkout/") or (http.request.full_uri contains "/cart/") or (http.request.full_uri contains "/my-account/") or (starts_with(http.request.full_uri, "/graphql")) or (starts_with(http.request.full_uri, "/xmlrpc.php")) or (http.request.full_uri contains ".txt") or (http.request.full_uri contains ".xlst") or (http.request.full_uri contains ".xml") or (http.cookie contains "no_cache") or (http.cookie contains "wordpress-") or (http.cookie contains "comment_") or (http.cookie contains "woocommerce_") or (http.cookie contains "PHPSESSID") or (http.request.full_uri contains "/panier") or (http.request.full_uri contains "/mon-compte") or (http.request.full_uri contains "/commander")

3- Cache everything else with also TTL Edge and brower cache of 6 months.

(http.host contains "asiasport.be")

I use APO and wprocket to handle unused css, javascript defering, ect…

What do you think is going on?

APO works best on its own without any additional cache rules.

Are you seeing resnok in your browser’s dev tools, or are you testing with curl?

Yes i use the developper tools. But I dont understand why my cache is being flushed every time on my home page.

If I remove wprocket what is the best solution for javascript defering, remove for unused css ?

And if you use Incognito Mode, does it still show resnok?

It’d also be best if you disabled your cache rules while you work on getting this straightened out. Please do that now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.