Origin is unreachable - Error code 523

My website is not working, Origin is unreachable - Error code 523. Help me please.
Website is working with real IP.

Web server - Nginx.

Nginx config:
`server {
listen 443 ssl;
server_name inopy.tech;

root /var/www/default/public; # Подставьте путь к публичной директории Laravel
index index.php index.html;

ssl_certificate /var/www/default/crt/inopy.crt;
ssl_certificate_key /var/www/default/crt/inopy.pem;

location / {
    try_files $uri $uri/ /index.php?$query_string;
}

location ~ \.php$ {
    include snippets/fastcgi-php.conf;
    fastcgi_pass unix:/var/run/php/php8.2-fpm.sock; # Уточните версию PHP
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
    fastcgi_buffer_size 128k;
    fastcgi_buffers 4 256k;
    fastcgi_busy_buffers_size 256k;
}

location ~ /\.ht {
    deny all;
}

}`

If you are listening on port 443 only, make sure you configure Cloudflare to “Always use HTTPS” here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates

Make sure your SSL certificate isn’t self-signed and your SSL/TLS setting is set to “Full (strict)” here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

Get an SSL certificate from LetsEncrypt or a Cloudflare origin certificate if you need one.

My certificare generated by Cloudflare.

Always use HTTPS - turned on.
SSL/TLS mode - Full (strict).

Do you have any firewall rules that may be blocking access from Cloudflare’s servers to yours?

You can temporarily set the DNS record to “DNS only” or pause Cloudflare to see if the domain name can connect directly to you server when bypassing Cloudflare.

If you say when that’s done, we can check from other locations.

I did not set the firewall settings to block requests.

When disabling the proxy server, the site started working, but for some reason SSL does not work, so I installed a certificate from Cloudflare, Origin server certificate.

What do you mean by that? Your configuration shows that you have SSL configured. If that didn’t work, the error message is to be expected because of that issue. A site always needs to work on SSL before you use Cloudflare.

Help me please.

Your server does not respond

$ curl -I https://inopy.tech
curl: (28) Connection timed out after 10000 milliseconds

You can verify this at sitemeer.com/#https://inopy.tech

I’ll write to my provider, maybe they have something wrong.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.