"Origin is unreachable Error code 523" w/ a Google Sites Host, only the naked/apex domain fails

I’m getting the following error:
Origin is unreachable Error code 523
… but only when the naked/apex domain is used.
i.e.
The plain domain fails, but adding the www. prefix will work.

The site is hosted at the New Google Sites system.

Every effort I have made to sort this out using CF Documentation, or the CF Community (past postings), and web searches has failed. (I find that I am unable to process the solutions offered.)

I have set up naked/apex domains in the past using cPanel at a typical host with no problem (but cannot recall now how I did it).

When the “club” I represent decided to drop the paid hosting (with the cPanel feature), our apex domain stopped working. Cloudflare was offered as a solution. I have been in “scramble” mode ever since, (now) spending way to many hours (over several weeks) on this, trying to locate the fix.

I have (finally) managed to get the full domain (w/ the www. prefix) to work on CF, but the solution for the naked domain is eluding me. (I sense that the solution is simple, probably a DNS record correction.)

I am completely stumped at the moment, and very frustrated (because I cannot seem to locate or interpret the solution myself (as I have usually been able to do in the past).

HELP!

The A record points to 192.0.2.1, a dummy IP that won’t go anywhere and should be covered by a redirect (likely to the www host) by a page rule or redirect rule.

Check the rule hasn’t been deleted or disabled…
https://dash.cloudflare.com/?to=/:account/:zone/rules/rules
https://dash.cloudflare.com/?to=/:account/:zone/rules/redirect-rules

2 Likes

Thank you!
I suspected that a redirect was the solution, but did not understand how to do that with the CF system.
I will try that.
cg

I setup a redirect rule:


… but now when I visit <socontra[dot]org> I get the error message:
This page isn’t working
socontra[dot]org redirected you too many times.
Try deleting your cookies.
ERR_TOO_MANY_REDIRECTS
… I have seen this before… but once again am unable to untangle the solution.

Check you are using Full (strict) in the dashboard here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

(at the moment I’m getting a timeout rather than too many redirects, have you disabled the rule?).

1 Like

I did (temporarily) disable the rule because even <www[dot]socontra[dot]org> started generating an error, completely disabling the site (even in a new “incognito” window).
… I have now “enabled” it again for this troubleshooting sequence.

I am using: “SSL/TLS encryption mode is Full (strict)”

Enter the static URL redirect as https://www.socontra.org

At the moment the redirect is being appended…
https://cf.sjr.org.uk/tools/check?1d1e4bab04c3400593980867743eaf67#connection-worker

2 Likes

YAY!
You (and this “Community” system) are AMAZING!
That seems to complete the “fix” sequence.

Many Many THANKS! (on behalf of myself, and my club community.
cg

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.