Origin DNS Error 1016


#1

I have a website (giveid.org) hosted on AWS elastic beanstalk and today Cloudflare started throwing Origin DNS Error 1016 when I try to load my domain. I haven’t changed any settings at all in months so I’m very confused as to what might have happened. The DNS records look correct and 3rd party services like Zonemaster are only report the following warnings:

“All nameservers in the delegation have IPv4 addresses in the same AS (13335).”
“All nameservers in the delegation have IPv6 addresses in the same AS (13335).”

Does anyone know how to rectify this?


#2

Are you using a CNAME or an A record for your domain? A 1016 makes me think one of these endpoints has changed on you.

If you set your domain to :grey: in the DNS page, does your site work?

As for those nameserver warnings, that’s normal and not an issue since Cloudflare’s DNS is so robust. Some DNS tools don’t like the idea of having all your DNS eggs in the same basket.


#3

Thanks for the reply. I’m using a CNAME to point to an AWS Load Balancer public DNS address. It’s weird because I can type that public DNS address into my browser and it resolves just fine, but for some reason it won’t work as a CNAME in Cloudflare even when I set the domain to :grey: in the DNS page.


#4

I’m also using the Cloudflare Load Balancer, and I determined that is the issue. When I switch it off the page loads fine. I wonder what changed with the Cloudflare Load Balancer recently?


#5

Go ahead and open a ticket with support if you would support(at)cloudflare(dot)com or through the support page. I’m not sure if we made any changes recently, but if we did I’d like them to take a look if you don’t mind.


#6

Thanks cscharff, I just sent an email to support.


#7

Thanks! I also sent a separate email to the LB team. Not sure what the issue is/was but wanted to get an extra pair of eyes on your report.


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.