Optimisation of WordPress site for mobile. Polish & WebP not working

Observatory is reporting that this site only scores 74 for mobile (93 for desktop).

The two main issues are First Contentful Paint 1.94s and Largest Contentful Paint 8.88s. The recommendation is use WebP and Polish, which I have already enabled, but they’ve made no difference and the src are still jpgs. The site is on the Pro Plan. Below is a screenshot of my settings.

Can anybody help solve why my config isn’t being applied?


Cloudflare does not change the filename. So you’ll still see a .jpg file even when it’s been served in a WebP format. You need to check the image headers, where you should find Content-Type: image/webp for converted images, as well as the CF-Polished header which gives you information regarding whether the file was converted, and in case it was not, the reason.