Only some of my users receive an SSL mismatch error

ssl

#1

Hello,
I activated before 10 hours the orange cloud instead of the grey cloud in my DNS for the website:

Meaning, traffic goes through cloudflare.
It worked before and it also works now, which is great.
Me and some of my other devices could access the website.

However, now after 10 hours I got messages from users who got this error ERR_SSL_VERSION_OR_CIPHER_MISMATCH .
I can’t reproduce it on my devices.

What should I check? It’s working for some and not for others.

My server side is using heroku, as I said everything is configured and it worked before and also works now for most users.

Thanks,
Eran


#2

SSL Test looks good. https://www.ssllabs.com/ssltest/analyze.html?d=solume.io&hideResults=on&latest

Can you find out which OS and Browser (and corresponding versions) those users are using? Can you get one of these users to more of a certificate check with their browser?


#3

Thank you for rest assuring me that it is probably at the consumer’s side.
I will try checking with the users.