Only some images are being flagged as needing cookie free


#1

I am running page test on GT metrix and all’s well except on Yslow and some , not all, images are saying :

There are 6 components that are not cookie-free

…logo-dark-opt.png

…responsive_design_opt.png

…home_page_designs_opt.jpg

…anna-goncharova-city-lights-full-screen-opt.jpg

I have removed the autoptomize ls scripts from the list

I added these images yesterday.
Any ideas why they are not behaving the same as the rest?

Thanks for any help you can give.
Ian


#2
  1. Dunno, but I have the same issue.
  2. Either way, I don’t worry about it, as it’s not a big deal. Cloudflare is going to add cookies, so there’s no way around that. Setting up some cookie-free way to serve static resources is going to do more performance harm than good.

#3

Thanks for the reply sdayman but the thing that is frustrating me is that all my other images don’t get this message.

Why just these 4? I can’t see how I have set them up any differently.


#4

My memory’s a bit better this morning. It was Pingdom’s Full Page test that’s done this to me. GTMetrix hammers me for cookies.

Would you mind posting the Report URL? I’d go to the Waterfall view and start expanding each entry to look for clues.


#5

Thanks for this sdayman.
I had the time down to 0.6 secs for a while now it’s over 3 and nearly all server resonse time.

https://gtmetrix.com/reports/www.jaiwebs.co.uk/HM8zPIXy


#6

That’s a horrid wait time. Something’s taking a ton of time to round up data from your server and get it to Cloudflare. Could autoptimize be the culprit? Are you running a Page Caching plugin as well? I really like WP Fastest Cache, since it’s simple and lightweight.

Personally, just to experiment, I’d disable Autoptimize and set up a Page Caching plugin.


#7

Yes I know sdayman, very bad response time. All the rest loads in no time.

Is resonse time down to the hosting company or how much the page content is… very fuzzy area for me this.

Autoptomize has been a real time cutter and was working great and then I added w3TC and all went even better!

Then when I tried to fix the 4 image file problem the GTmetrix scores went up while the wait time also went up :frowning:

Feel like it time to start from the beginning. At least I know all the images are optimized.


#8

Here’s a handy tool:

Check out the section on Performance Troubleshooting. Then scroll up a bit to find the curl command that uses --resolve The ‘resolve’ flag will go directly to your origin server. No ‘resolve’ flag will hit that page through Cloudflare.

By using both versions of the command (with, and without ‘resolve’), you get a very good comparison of with, and without Cloudflare for just the main page HTML.


#9

Thanks again sdayman. Sorry for the late reply got a site down :frowning:


#10

This topic was automatically closed after 14 days. New replies are no longer allowed.