One tunnel two connectors

Hi, hope somebody can help me out.

I’m running Cloudflare tunnel in Docker, on Ubuntu 22.04.
Recently I moved server to a location with better internet, but behind CGNAT. Now, everything used to work fine until it didn’t - from what i managed to troubleshoot, i can’t reach anything on tunnel if, for some reason, i have two connectors up for one tunnel.

I restarted docker, deleted the image, pulled it again - and it works as long as there is one connector for that particular tunnel. Now, what triggers second connector to run? Can i stop it?

Hi @dimitrije.djordjevic

To prevent a second connector from starting, you can ensure that you only have one instance of the cloudflared service running. Here’s a step-by-step guide:

  1. Check for running instances of cloudflared by executing docker ps in your terminal.
  2. If you find more than one instance, stop the additional instances using docker stop <container_id> for each one.
  3. To prevent automatic restarts, check your Docker configuration (possibly in a docker-compose.yml file) to ensure that you don’t have settings that would cause multiple instances to start, such as restart: always under multiple services.
  4. If you’re using a configuration file for cloudflared, ensure there’s only one tunnel specified and no duplicate entries that could cause a second connector to initiate.

There is just one instance of cloudflare when i run docker ps - i was sure to stop all existing docker instances and to pull image again.
But it still runs two connectors after a while (haven’t really seen the pattern), and then it stops accepting connections.

I solved the issue - apparently, when setting up SSH tunnel, i mistakenly activated second tunnel on a different device, instead of just installing cloudflare access service, without tunnel.

Removing a tunnel from my computer solved it - now with one connector running (on a ssh server machine), everything is working as intended.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.