One Site Works - One Doesn't?


#1

Hello,

I have 2 websites, I’ve turned on SSL for both of them through cloudflare, but one site isn’t working while the other is fine. I had originally set one site for flexible and that one is fine. The other one I set for strict, and I had issues, so I switched to to flexible but the issue is persisting. Would someone be able to shed some light on what could be happening?

I host with ipage for both sites and use both wordpress and woocommerce on both sites.

Any info you could provide would be really helpful! Thanks so much!


#2

What issue exactly? Do you have any error messages for us, or would you mind to post the URLs?


#3

The entire site loads strangely. If I go to http://luxexo.com it loads fine, but if I go to https://luxexo.com it doesn’t load correctly.


#4

my other site works fine with both http://enticethebrand.com and https://enticethebrand.com


#5

ooops correction, http://luxexo.com still doesn’t load completely…but it looks better than when I try to access it as https


#6

You have mixed content here. You are trying to load HTTP links from the HTTPS page and current browsers are not too fond of that :wink: and simply dont load those resources.


#7

That looks like a “simple” JavaScript issue, it throws an error and I assume that will be the reason why it does not continue rendering the page.


#8

As for the mixed content

might be of help


#9

mixed content seems not the main issue here, there is alsmost no content via HTTP as well. :astonished:

@nadi.russ
As there is a lot of JS: Is Rocket Loader active?


#10

On HTTP it freaks out because of a JavaScript issue, on HTTPS because of mixed content.


#11

Ok… Thanks so much! So how would I be able to fix that?


#12

Sorry, I’m not very techy… I use wordpress and for this particular site I am using siteorigin. I think it used JS


#13

You should enable HTTPS Rewrites for the mixed content, everything is on your domain, so no issues there.
Ideally you should use relative URL, so it will never happen something like this.

For the JS issues it would be useful to check the code, do you have Rocket Loader enabled or minification?


#14

You can find the Rocket loader in your CF dashbord under the “Speed” tab. This little guy is causing issues with JS sometimes.

And as @matteo wrote: check “auto minify” (same tab) and play around with it.


#15

Yeah, try and disable both, then clear the cache, then enable one at a time.


#16

I’m going to check, not sure what rock loader is… but I do have minification enabled. Easy load I think… since it’s a photo rich site.


#17

Ok thanks!


#18

Awesome, I’m going to check this now. Thanks!


#19

JS minification is different than image optimization… the latter is only available on paid plans.


#20

I just realized that. I didn’t have rocket loader or minify activated. I just toggled them on now. @MarkMeyer