One site only shows default cgi


#1

Hi
I have 8 sites and only one with a problem. It shows the system default page and I can not get rid of it.
/cgi-sys/defaultwebpage.cgi
https://diycandlesupplies.com.au/cgi-sys/defaultwebpage.cgi

I have cleared the DNS cache on my computer plus browser cache many times but nothing changes. As I said all other sites set up with cloudflare work fine ??


#2

It’s not using a 301/302 Redirect. There’s something there with a Meta Refresh head.

If you go to the Cloudflare DNS page and change the DNS entry to :grey: to bypass Cloudflare, does it work?


#3

By passing only cause this error


#4

It looks like you switched it back to :orange:, so I can’t check it.

Did your site work before you added it to Cloudflare?


#5

Yes I switched it back as I did not know you wanted to test anything. Yes it worked fine before cloudflare. I will bypass again for you now, thanks


#6

I see it’s not using Cloudflare right now, and I’m still seeing the Meta Refresh that redirects to that error page.

Did you add it to Cloudflare via cPanel? If so, then I suggest you leave it in :grey: and ask your host for support to get it working again before you switch it to :orange:.


#7

p.s. Are you sure you have have the correct IP address in DNS?


#8

I added the site via cloudflare dashboard.This site is the only one that I had to manually change the IP to,173.236.55.90 which is what my other sites had in their settings. All other sites worked out of the box with cloudflare auto changing IP.
The DNS on the name servers is exactly what cloudflare shows in the settings, igor.ns.cloudflare.com|

uma.ns.cloudflare.com|


#9

What was the old name server for that domain?


#10

It is a new site and still under construction so its always been on the server.


#11

It’s probably the wrong IP address. Can you go to your cPanel account’s Zone Editor and try to track down the IP address of your new site? I suspect it’s not what you manually set it to.


#12

I did not set it in cpanel as I did not need to with the other sites but it looks like you are correct as its not cloudflare’s IP


#13

I’m able to get to your website by forcing my browser to use the IP address in your screenshot.

Update the DNS entry in your Cloudflare DNS page to use that correct IP address.


#14

It is but it still shows cgi page no matter who much l clear DNS cache through ipconfig /flushdns and clear browser cache.


#15

Your IP addresses are wrong. They all should be 184.154.10.122


#16

If that wrong then why are 7 other sites using a that IP? Remember it was cloudflare that does that during set up?


#17

Host IP addresses sometimes change. And if it’s a new domain, some hosts put them on a new server as the old server fills up.

Have you tried updating the IP addresses in your Cloudflare DNS page for this domain?


#18

What I did was change all IPs to what the other sites were using plus cpanel zones but now I’ve changed them all back to 184.154.10.122. At this point its still the same as in default page so I guess will wait and see what happens.


#19

One last check… What’s your SSL set to? It should be Full (not strict). The SSL certificate on your origin server doesn’t match your domain. Flexible should work as well, but I’m seeing an SSL certificate on your web server that matches *.websitehostserver.net

Oh, and just to be complete…go to the Cloudflare Cache page and Purge Everything.


#20

SSL is full. I dont know where the websitehostserver .net comes from. Yes I purged all thanks.