One.one.one.one can't find www.espoo.fi: Server failed

Hi,

I’ve experienced issues for a couple of weeks at least accessing our city domain using cloudflare dns. What could be the issue?

It’s resolving for me through my local 1.1.1.1

Hi, thanks for this. We’ve tested on multiple different ISP:s in Finland and all have the same issue. Azure germany / Sweden working fine also.

1.1.1.1 — the Internet’s Fastest, Privacy-First DNS Resolverf169vf_gaMTM3MjM0ODg4My4xNjM3Mzk0NTY2_gid*MTk3NDk4ODAyOS4xNjM3Mzk0NTY2

Output of the commands:
PS C:> nslookup example.com 1.1.1.1
Server: one.one.one.one
Address: 1.1.1.1

Non-authoritative answer:
Name: example.com
Addresses: 2606:2800:220:1:248:1893:25c8:1946
93.184.216.34

PS C:> nslookup example.com 1.0.0.1
Server: one.one.one.one
Address: 1.0.0.1

Non-authoritative answer:
Name: example.com
Addresses: 2606:2800:220:1:248:1893:25c8:1946
93.184.216.34

PS C:> nslookup example.com 8.8.8.8
Server: dns.google
Address: 8.8.8.8

Non-authoritative answer:
Name: example.com
Addresses: 2606:2800:220:1:248:1893:25c8:1946
93.184.216.34

PS C:> nslookup -class=chaos -type=txt id.server 1.1.1.1
Server: one.one.one.one
Address: 1.1.1.1

Non-authoritative answer:
id.server text =

    "HEL"

PS C:> nslookup -class=chaos -type=txt id.server 1.0.0.1
Server: one.one.one.one
Address: 1.0.0.1

Non-authoritative answer:
id.server text =

    "HEL"

PS C:>

PS C:> nslookup -type=txt whoami.Cloudflare.com ns3.Cloudflare.com
Server: ns3.cloudflare.com
Address: 162.159.7.226

whoami.Cloudflare.com text =

    "193.106.11.245"

PS C:>

https://dnsviz.net/d/espoo.fi/dnssec/

@mvavrusa usually tracks these issues down, but it’s the weekend and it may have to wait a day or two.

In the mean time, can you edit the Title of this post so you can change the Category to DNS → 1.1.1.1?

This is odd, it seems like the v6 for fi nameservers returns truncated response back, but then doesn’t support TCP:

$ kdig @f.fi espoo.fi DS +dnssec  -6

;; WARNING: truncated reply from 2a00:13f0:0:3::[email protected](UDP), retrying over TCP

;; WARNING: can't receive reply from 2a00:13f0:0:3::[email protected](TCP)

;; WARNING: truncated reply from 2a00:13f0:0:3::[email protected](UDP), retrying over TCP

;; WARNING: can't receive reply from 2a00:13f0:0:3::[email protected](TCP)

;; WARNING: truncated reply from 2a00:13f0:0:3::[email protected](UDP), retrying over TCP

;; WARNING: can't receive reply from 2a00:13f0:0:3::[email protected](TCP)
;; ERROR: failed to query server [email protected](UDP)

I’ll see what we can do and try to contact .fi as well.

1 Like

I’m seeing the same. Sometimes it resolves, sometimes it does not.

~ % dig espoo.fi @1.1.1.1 +nsid

; <<>> DiG 9.10.6 <<>> espoo.fi @1.1.1.1 +nsid
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6471
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; NSID: 37 39 6d 35 36 ("79m56")
; OPT=15: 00 03 ("..")
; OPT=15: 00 06 ("..")
;; QUESTION SECTION:
;espoo.fi.			IN	A

;; ANSWER SECTION:
espoo.fi.		1	IN	A	35.228.250.182

;; Query time: 44 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Mon Nov 22 18:30:03 CET 2021
;; MSG SIZE  rcvd: 74
~ % dig espoo.fi @1.1.1.1 +nsid

; <<>> DiG 9.10.6 <<>> espoo.fi @1.1.1.1 +nsid
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 18477
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; NSID: 37 39 6d 34 32 ("79m42")
; OPT=15: 00 06 ("..")
;; QUESTION SECTION:
;espoo.fi.			IN	A

;; Query time: 40 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Mon Nov 22 18:30:04 CET 2021
;; MSG SIZE  rcvd: 52

These were from a Finland location but it also happens in Amsterdam.