One of my website's page is not fully cached

Hi !

Since Sunday morning I use CloudFlare for this web hosting company : https://grape-hosting.com/

I enable full page caching for each page except for page with dynamic content (user panel, etc.)

All works perfectly good as usual, except that one page (the homepage), take a very long time to load.
We are using CloudFlare cause this Web Hosting company use WHMCS which is natively slow (all pages were loaded in 15-20sec).
All the pages now load in 1-5sec, but the homepage (https://grape-hosting.com) always takes 20 seconds to be loaded (like if it the origin server was yet requested each time).

I activate the Browser Insights, and I join you the picture that show that there is a real problem with the homepage (the third line of analytics picture).

Thanks in advance for your help,
Lilian.

Would you mind sharing the page rule you set up for caching?

Thanks for the very fast answer, yes sure, wait a minute :slight_smile:

@TomKlein

Your page rule seems right. I looked into it and all your pages show that the request bypasses the cache. It may be due to cookies being set.

Another thing that could be linked, all pages of the website work at the Google PageSpeed Insight tool, except the homepage, Here is the error message :
Lighthouse returned error: FAILED_DOCUMENT_REQUEST. Lighthouse was unable to reliably load the page you requested. Make sure you are testing the correct URL and that the server is properly responding to all requests. (Details: net::ERR_TIMED_OUT)

1 Like

NB : I changed my username, I’m user3255

My guess is that the page took too long to load and hit PageSpeed’s time limit. What I think is that Cloudflare isn’t caching your content at all because cookies are set on request.

Thanks for your answer. What could I do for that ?
This afternoon I tested another page rule and the CF headers no more indicate that the pages were bypassed, but the homepage take yet a long long time to be loaded.

I’d recommend looking into why your site is loading that slow in the first place. It’s not usual it’s taking so long. An alternative would be caching it on your server.

For the cookies: I guess your CMS automatically sets this cookies and they might be required for things like shopping cart features.

You could also try to set Edge TTL to something larger than 0 in your page rule but that’s just a guess :smile:

I can’t do anything to increase performances on my side, all the WHMCS’ code is obfuscated by ioncube :confused:

Where can I edit Edge TTL ?

Just edit your page rule and add that as a second setting.

While you do have a page rule that’s set to cache everything, it seems like your website has set the cache-control header to prevent Cloudflare from caching that page.
image

Cloudflare will not cache a page if the origin server’s response explicitly says to not cache the page.

3 Likes

Thanks ! I am going to try

Thanks ! Do you how can I easily change that ?

That should be overwritten if you set an Edge Cache TTL of > 0.

1 Like

@_lilian Congrats! Seems to work for me now :smile:

1 Like

Yes the CF header indacte DYNAMIC, but the page take yet 20 seconds to be loaded, exactly like this afternoon :confused: