One of my users (but not the others) is repeatedly getting a 520 error

One of my users (but not the others) is repeatedly getting a 520 error.
What can I do to help her? Any idea why a 520 error could affect only one user?

Greetings,

Thank you for asking.

May I ask if it’s the same hosting/server for all, and it happens on only one particular domain using Cloudflare while the other domains are also on Cloudflare, or? :thinking:

Regarding Cloudflare 520 error, may I suggest you to take a look for into below article to troubleshoot the issue:

Before moving to Cloudflare, was your user’s Website working over HTTPS connection?
You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

Furthermore, if you have been through all these above suggestion and are not seeing corresponding issues on your network/server and you have a ticket number with Cloudflare, please reply and post that ticket number # here.

To enable efficient troubleshooting by support, please ensure you include the following on the ticket:

  • example URL(s) where you are seeing the error
  • Ray IDs from the 520 pages
  • output from a traceroute from any impacted user
  • output of example.com/cdn-cgi/trace - replace example.com with the affected domain.
  • Also include two HAR file(s) : one detailing your request with Cloudflare enabled on your website and the other with Cloudflare temporarily disabled - see How do I temporarily deactivate Cloudflare

Yes. Only one server. She is getting this on the log-in page.

Great, thank you for feedback information.

May I ask if it is a WordPress login page, or some other?

Wordpress. Subscription website.

Might be the SSL issue or if using some kind of a firewall plugin which might block the connection :thinking:

Could you try to provide an answer on some of my questions from my first post, to not post them duplicated again?

Actually, the website is WordPress-based but the login page is from the Memberpress plugin (is that what you asked?).

Before moving to Cloudflare, was your user’s Website working over HTTPS connection? Yes.
You could determine this by:

  1. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict). Yes. The SSL is working.

May I ask what SSL option have you got selected under the [SSL/TLS tab].? I am using Full

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article: done

Kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share the ticket number here with us so we could escalate this issue: I did, thanks

Furthermore, if you have been through all these above suggestion and are not seeing corresponding issues on your network/server and you have a ticket number with Cloudflare, please reply and post that ticket number # here. I am still waiting for their response

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.