One member is unable to log into my site since setting up the SSL

I have a domain with a Zencart store and a WordPress blog.
One customer created her account and completed a purchase a couple of weeks ago, with no issue. Since last week (as she wanted to make a purchase) she is unable to login.
We eliminated issues with the browser, the device, the actual account in the store, and such. The only thing we are left is me installing the SSL since her last purchase.

Thinking initially that it was only a Zencart issue, I have been in touch with their community support and all our “tests” seem to point to something with my SSL but it is a foreign language to me. Here is what they said:

When accessed without www. all of the internal links point to https: and the page is redirected to https: when accessed with http:. BUT if the page is accessed with the www. prefix, then the internal links are http: as if the page is not recognized to be loaded with the SSL. At the same time, a mixed content message is provided… This is something I’ve not seen before. Usually even if the site has been reachable with www. and the certificate expected non-www. the links would still be https: but the page format may be text on white… (CSS not loaded)

Would anyone be able to help me make sense of this suggestion/explanation? Maybe I did something wrong in setting my SSL? Or I missed something?

The store is https://creationcassel.com/store/

Add a Page Rule in the Cloudflare Dashboard:

Match: www.creationcassel.com/store/* and add a setting for Forwarding URL (301) to https://creationcassel.com/store/$1

This should drop the www and send a user to HTTPS.

I would love to try that, however, i would need some instructions a bit clearer as it is all foreign for me. Where do i set that rule? And is the $1 the actual code to use or just a placeholder?

Just like this:

1 Like

What is the $1 for?

It forwards the path as well. It represents the * from the Match.

Oh ok… thanks. I knew about the * but never knew about the $1 (especially considering that i am dealing with e-commerce site!)

1 Like

So far, it has not solved the initial problem of the user not being allowed to log into the store, so the ZenCart community offered other “suggestions”:

Interesting that you just have mentioned that you are using cloudflare. I thought that “service” offered caching of pages to speed up load time. Considering that the ssl certificate has changed and although the pages are served all https:, two things.

  1. are you able to either request cloudflare to clear their cache or temporarily disable cloudflare for testing purposes,
    …
    Would you be able to direct me to the right place to possibly do that?

From the Overview tab in the Cloudflare Dashboard, there’s a “Development Mode” toggle that will turn off caching for your domain.

Is turning off the caching the same thing as clearing it?

Similar. Dev Mode means there’s no caching. It’s good for troubleshooting. Give it a try.

OK will try as soon as I can.
Will report back after.

1 Like