On some locations 1.1.1.1. answer with 127.0.0.1


#1

dig -c CH -t txt id.server +short @1.1.1.1
“VIE”

curl ‘https://cloudflare-dns.com/dns-query?ct=application/dns-json&name=festo.com.ly&type=A
{“Status”: 0,“TC”: false,“RD”: true, “RA”: true, “AD”: false,“CD”: false,“Question”:[{“name”: “festo.com.ly.”, “type”: 1}],“Answer”:[{“name”: “festo.com.ly.”, “type”: 1, “TTL”: 120, “data”: “127.0.0.1”}]}

dig -c CH -t txt id.server +short @1.1.1.1
“FRA”

curl ‘https://cloudflare-dns.com/dns-query?ct=application/dns-json&name=festo.com.ly&type=A
{“Status”: 0,“TC”: false,“RD”: true, “RA”: true, “AD”: false,“CD”: false,“Question”:[{“name”: “festo.com.ly.”, “type”: 1}],“Answer”:[{“name”: “festo.com.ly.”, “type”: 1, “TTL”: 88, “data”: “141.130.250.196”}]}

?

How to fix 1.1.1.1 ?

Best regards,

MF


#2

The domain’s authoritative nameservers are not in sync and return contradicting values.

nslookup festo.com.ly ns0.atvirtual.com
Server:  ns0.atvirtual.com
Address:  176.124.112.9

Name:    festo.com.ly
Address:  141.130.250.196
nslookup festo.com.ly ns1.atvirtual.com
Server:  ns1.atvirtual.com
Address:  176.124.113.9

Name:    festo.com.ly
Address:  141.130.250.196
nslookup festo.com.ly ns2.atvirtual.com
Server:  undefined.hostname.localhost
Address:  185.136.96.210

Name:    festo.com.ly
Address:  127.0.0.1
nslookup festo.com.ly ns6.atvirtual.com
Server:  undefined.hostname.localhost
Address:  185.136.97.210

Name:    festo.com.ly
Address:  127.0.0.1

#3

Thank you. Sorry. No need to fix 1.1.1.1. I fixed it here.