On Prem Git behind Cloudflare Proxy - 503 error

Hey all

Sorry if that has been covered, searching was yielding nada.

I have an on-premise gitlab that is proxied behind Cloudflare, and when I try do a git push i get 503 (I assume its hitting browser challenge)

I tried to drop security and create WAF policies to permit the PUSH and HEAD methods to no avail.

Has anyone come across this and an idea on what I need to set to get it working? Sadly there’s no tangible logging on Cloudflare for me to diagnose through its console.

Cheers

Is Git setup to point at the remote with SSH or HTTPS?

Only HTTPS will work with Cloudflare proxy, you’d need Cloudflare Tunnels or Spectrum for SSH.

If it’s being blocked by Cloudflare then it’d appear in https://dash.cloudflare.com/?to=/:account/:zone/security

https only.

i put straight up allow rules, and tried page rules, disabled security, disabled challenge. still blocks.
bypass Cloudflare and it works :confused:
in the WAF logs I only see the initial GET requests, no HEAD/PUTs

I should also add, i am not seeing any requests come through to the internal server so its never being passed on from Cloudflare.