On Microsoft Edge, my cloudflare SSL certificate is not valid

Hi -

My website seems to have no issues with the SSL certificate, except when visiting via my Micrososft Edge browser.

Then it gets a safety warning and a note that the certificate, which comes from Cloudflare, is not valid. It blocks the user from proceeding by warning that the website isn’t safe.

I’m completely clueless about everything and am having a really hard time wading through all the information about SSLs.

My website is friedavizel.com

Thanks for any help!

Can you post a screenshot of the certificate details? I’m looking for info such as Subject Name, Issuer, Common Name, etc.

1 Like

Thanks for replying!

Does this work?

It sure looks valid and passes the Qualys SSL test. Can you post a screenshot of the Edge warning?


1 Like

See here, it says the certificate isn’t valid.

I viewed it on edge without issue.


It says you’ve chosen to disable security warnings. Yet it’s still warning you. Is that some sort of cached warning? What happens if you Re-enable warnings?

1 Like

I reenabled warnings and cleared the cache, and tried via inprivate browser. This is what I get:

PS Thanks so much for your timely replies!

Huh! I restarted, I still have the issue.

Do you only see it on the admin link or if you just browse the main page? That is a pretty specific error.

I get it by just visiting the home page, regardless if I’m logged in. Is there something I can do about this error?

It would seem that the cert was created and logged by the CA (Cloudflare). It’s working for others, like myself.

Are you on an updated version of Edge?

1 Like

Yup, I’m working on an updated version of Edge. I don’t know! Thanks for all your replies! If you have any other ideas, please let me know.

Honestly, I am at a point where it’s either something specific to you (AV, Browser extension, different setting) or you may want to re-issue the cert. I can’t duplicate the issue and the error is either a configuration issue or an issue with the CA. It doesn’t appear to be either of those issues.


It somehow now works. Thanks to both of you - really helpful!!!


This topic was automatically closed after 31 days. New replies are no longer allowed.