Old expired SSL still showing

Hi guys,

Sorry if this has been asked before, but i could not find anything just like this problem.
I have a client who has bought the SSL from his current host and now it has expired (Today)
We want to move to cloudflare for the encryption and free SSL.

For some reason, even though everything should be setup correctly, the website is being labeled as “Not secure” in the browser (in incognito as well as on the phone)

I can see that it is still catching the old expired SSL and therefor not getting the new one from cloudflare. Do anyone know how to fix this?

The mode has been on Flexible but now moved to Full

Thank you guys in advance!

You didn’t post the domain name, so we can’t check anything, but you still need SSL on the server. Cloudflare has an Origin CA cert you can install at the server:

If it cached the expired certificate and you cleared your browser’s cache, your traffic probably isn’t proxied through Cloudflare. Did you enable the :orange: Proxying?


Edit: For me, the domain is working with SSL. Maybe your computer or browser cached the non-Cloudflare IP address.


Edit 2 (as I currently can’t post new content): If you want to clear your cache, you could do these things:

In Google Chrome:

chrome://net-internals -> DNS -> Clear Host cache
chrome://net-internals -> Sockets -> Flush socket pools

Windows (as administrator):

Open cmd.exe -> ipconfig/flushdns

The domain is: Energikoeb.dk

Would be awesome if you could check it!
And confirm if the origin CA certificate is what i need.

That is strange, if that is the case changing it to “Full” must’ve done the job. But i still dont see it, not in incognito or on the phone for that sake.
image

I just tried to clear all cookies in the developer console, but i still cant see it. do you have another way of clearing the non-cloudflare IP?

1 Like

It’s secure for me, so whatever’s causing that warning appears to be at your end.

If you click on the :warning:, does it give you more information?

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.