Old domain just turned to DNS_PROBE_FINISHED_NXDOMAIN

Just to let you know again that this issue happened on our old domain which just turned DNS_PROBE_FINISHED_NXDOMAIN by itself

so we have the domain arcellatelecom.com and is added to Cloudflare with everything working correctly, but yesterday we had the error DNS_PROBE_FINISHED_NXDOMAIN out of the blue, nothing changed in the domain nor Cloudflare configuration.

We have servers located in Germany and we tried to access the website from there and it works without any issue, but locally here in Iraq all our nslookup attempts failed.

> arcellatelecom.com
Server:  dns.opendns.com
Address:  208.67.220.220

*** dns.opendns.com can't find arcellatelecom.com: Server failed
> server 1.1.1.1
Default Server:  one.one.one.one
Address:  1.1.1.1

> arcellatelecom.com
Server:  one.one.one.one
Address:  1.1.1.1

*** one.one.one.one can't find arcellatelecom.com: Server failed
> server 8.8.8.8
Default Server:  dns.google
Address:  8.8.8.8

> arcellatelecom.com
Server:  dns.google
Address:  8.8.8.8

*** dns.google can't find arcellatelecom.com: Server failed
>

and here is our server response
EDIT: Server response was due to cached DNS record, nslookup failed locating our dmain

[[email protected]******* ~]# curl https://arcellatelecom.com/ -I
HTTP/1.1 200 OK
Date: Mon, 14 Feb 2022 06:59:30 GMT
Server: Apache
Upgrade: h2,h2c
Connection: Upgrade
Last-Modified: Mon, 14 Feb 2022 06:41:17 GMT
ETag: "1379a-5d7f4b41f015f"
Accept-Ranges: bytes
Content-Length: 79770
Vary: Accept-Encoding
Referrer-Policy: no-referrer-when-downgrade
Pragma: public
Cache-Control: max-age=3600, public
Content-Type: text/html; charset=UTF-8

[[email protected] ~]#

and this is our local request

C:\Users\****>curl https://arcellatelecom.com
curl: (6) Could not resolve host: arcellatelecom.com

C:\Users\*****>

No , I see a arcellatelecom.com ’s server IP address could not be found. In India

I am trying to narrow it down but can’t locate the issue.

Hmm . Have you entered correct Ip adress in Your A Record ?

The website was working fine just yesterday, nothing changed since, and even if I entered a wrong IP, Cloudflare incorrect IP address page should appear right ?

I have checked and seems like an issue with the DNSSEC at Cloudflare → same error I see while using an online tool and you both are using Google LLC Domains (the same registrar).

I’ve addded your topic to an already similar issue to escalation:

Kindly and patiently wait for a reply from someone of Cloudflare Team.

2 Likes

Thanks for flagging. Escalated internally to identify the cause and possible solution

1 Like

Hello,

Unfortunately with registrar configs we do not find any issues. Is it possible for you to toggle DNSSEC (turn off and on) to see if it helps.

If it does not I might have to reach out another team.

Please let me know if this helps.

2 Likes

Thanks for the reply, I noticed that it was enabled and once I disabled it, the website DNS works as indented.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.