Old cache persist

hello everyone,

I have a problem with the cache, it turns out that my site loads an older version for everyone and in all browsers, except for me in chrome, but if I access from another browser I see the old cahcé.

As soon as I stop using the Cloudflare name servers everything goes back to normal.

I have cleared the cache from the Cloudflare panel but nothing happens, I don’t know what to do, has anyone had something similar happen?

Thanks in advance.

Greetings,

Thank you for asking.

Kindly, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” tu flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out.

Nevertheless, may I ask if you might be using some kind of a custom-made Page Rules which for you can check by navigating to the Cloudflare dashboard → Rules → Page Rules for your domain name? :thinking:

Hey friex,

I have made your recommendations, but I had no success, and I don’t have rules configured. The old version of my site starts with a transitions, the current version doesn’t have, so I always see those transitions on othe browsers and my cell phone, only on my macbook throug chrome I can see the current version.

Thanks a lot for your help!

Can you share your website URL so I we could also check and post what do we see to compare and test, if so? :thinking:

May I also ask if you have used since before Cloudflare for your domain name?

Furthermore, did you used some kind of a 3rd-party provider like Shopify maybe or some dkind of a web hosting provider?

And for sure, the A domain.com is pointing to the correct (new) IP address (or CNAME if you’re using that kind of a setup)?

Sure thing,

My site is: aripromot dot com, I’ve been using Cloudflare for a few months really and never I had problems, just now.

For now I’m using a VPS from Interserver with a panel called Webuzo, my site is made in wordpress and I use WP Rocket to manage the cache.

Yeah, I’ve the correct IP pointed on my A records as @, * and www, I haven’t CNAME record, but when I try to add it I get an error message "DNS Validation Error (Code: 1004) Content for CNAME record is invalid.”, but before all was perfect, I don’t know why I’m getting those mistakes.

If you have an idea I would be really grateful!

Thank you for feedback.

This is what do I see:

I remember there were topics about WP Rocket + Cloudflare, therefore I suggest you to look up at the below articles in that terms just in case if you’d have some issue later - but you might not have or experience them. Some do, so I’d just like to share them below in case if happens in future:

Thanks, I’ll take a look!

the current version and the old one are identical, except for the transitions, the old one has transitions in the hero texts, the current one doesn’t.

If you could see transitions in the hero texts when the page loads, it means that you are seeing the old version.

I have no idea what could be causing the problem. :sleepy:

I think it could be related to CSS/JS and WP Rocket.

Otherwise, try temporary disabling the Rocket Loader option from CF dash → Speed → Optimization, if anything different :thinking:

Also, is Auto Minify enabled for HTML, CSS & JS at CF dash → Speed → Optimization? :thinking:

In fact I have just uploaded a patrick png, on chrome it’s possible to see the image, but on firefox and other browsers simply not, just type /patrick.png at the end of my domain.

And also I have disabled wp rocket, I have cleaned cache and nothing, patrick can’t be seen.

And yes, those options are on.

Intersting :thinking:
I can’t see it on neither web browser, on both I got 404.

For your homepage, I can see the:
cf-cache-status: MISS

It suggests me that you’re trying to cache a HTML too with Cloudflare.
May I ask if you are using Cache Level: Cache Everything within some Page Rule, which might be enabled? :thinking:

Furthermore, for some resources I get:
cache-control: max-age=31536000, public

Meaning, your origin is sending those, or rather WP Rocket itself.

Try to disable Auto Minfy for all 3.

UPDATE:
Ok, now I got this HTTP headercf-edge-cache: cache,platform=wordpress.

Which suggests me you’re also using Cloudflare APO for WordPress? :thinking:

  • meaning APO is caching the HTML pages … (despite the above statement about Cache Level: Cache Everything)

May I ask if you already tried purging the cache via APO? :thinking:

You’re also using some 3rd-party tool for uploading/serving or optimizing images like optimole?

Just in case, kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

The Caching Level I have configured is Standard, but I have no rules configured.

I don’t using Cloudflare APO, but if I have somehow unknowingly enabled that where could I clear the cache?

Yeah, I’m using Optimole. I’ll open a ticket for share it here.

I appreciate a lot your help! :pray:

Hey fritex good day!

I made a new account on Cloudflare and connected my site there, the problem persisted, I also removed my site on my hosting and make it again, but the problem persisted.

Which makes me think it’s some conflict related to my hostig, but since I have no idea about anything, I’ll try to get support to give me a hand, I’ll go pro just for receive support assistant.

Thanks for your help!

Hey guys,

I have been trying for days to fix the stuck cache problem on my site, I have not been able to find a solution here on the forum.

I have reinstalled wordpress from scratch and it is still loading the old version. Mi site is aripromot[dot]com.

In another post I was recommended some options but nothing worked, the last suggestion was to contact support but I have had no luck, I just don’t get a response, I even upgraded to the pro plan to get help from support but I get no answers.

I have a couple of other sites connected, but the problem only occurs on my main site, all sites are made in wordpress and all use wp rocket.

I would like to find a solution to this problem, it has me with a headache guys,

Thanks. :pray:

Could you share a ticket number here with us so we could escalate it, if so (already mentioned)? :thinking:

Cache isn’t the prettiest thing to configure :confused:

Sure, the ticket number is 2504803 :smiling_face_with_tear:

1 Like

Hi there,

Sorry for the trouble on this. I have replied on your ticket. Please let us know if we can be of any further assistance.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.