OG Meta Tags Do Not Work

So I am hosting my website/web-server on Google Cloud Platform, and I have proxied the requests through Cloudflare. However, when I try pasting the website URL in my Discord server it will not show the image. The OG Meta tag I used was og:image. The image does show on the HTTP version but not on the HTTPs version. I do not know why this is happening, because before using Cloudflare it was working correctly on the HTTPs version of the website/web-server.

Here is my website URL:
https://hades-ss.xyz

Is og:image the only tag you have?

Kindly, can you try having all of these if it helps a bit? (consider the cache on their servers if so):

Or it has to be something else on the Discord side why does it show on HTTP but not on HTTPS.

How about using <your_https_link> with those angle <> brackets?

Nope, I have other tags like og:title, og:description and all of those shows but not the image. And when I try to check the meta tags on an online site that allows me to preview embeds they work but not the image. So it’s not on Discord’s side.

And I do not think that article would help because I tried using og:image:secure_url earlier and it doesn’t work, too.

Do you have Hotlink protection enabled on Cloudflare?

I do not have Hotlink Protection on in the Scrape Shield section.

Okay so it works now, all I had to do was to disable the “Under Attack” mode.

Of all the bizarre side effects of Under Attack Mode. I wonder if this is intentional. Maybe @mdemoura has heard of this.