Odd problem of indexing only one http page in Google

Hi,

I have a website w w w . tarkacomputercare. c o.u k

It has up until very recently all been working just fine - I got it all setup nicely last year and made various changs and tweaks to get it all behaving well.

I added a new page back in April called …/covid.html. I have the setting http://tarkacomputercare.co.uk/ Always Use HTTPS as a page rule.

If I do a custom google search for site:tarkacomputercare.co.uk There is one rougue page coming up in the search results - note that it has a single w instead of www ?!?:

This page is not referenced anywhere on my website at all and you can see that it is a non https page too coming up in the results whereas all of the other pages I can only see the desired https pages indexed.

I have checked everyting I can think of but cannnot find a reason this non https page is ever getting indexed. It is not getting indexed on Bing - only Google.

Can anyone please shed some light on this for me?

Thanks
Paul

Here is an image of the odd result I can see:

I think you have a DNS record for w.tarkacomputercare.co.uk. If this is not intended, just delete it.

mu site www.dietaedietas.com.br estava com os mesmos problemas

Hi Erictung. I am a bit of a novice with this but I have checked my settings for DNS and Nameservers.

On my hosting platform the nameservers are set to:

cheryl.ns.cloudflare.com
donald.ns.cloudflare.com

on Cloudflare under DNS there is no entry for w.tarkacomputercare.co.uk

the DNS recored is as follows (with number obsfucated):

also… If it were a DNS record error would I expect to only see one search result for the whole of my site pointing to w.tarka******* If it were a DNS problem would I not see every page in the results duplicated to w.tarka******* ??

I’m not sure what to do.

Thanks
Paul


You have a wildcard DNS entry on the fifth row from top, so any (host)name that’s not explicitly added as a DNS entry will fallback to that fifth row, which is why w.tarkacomputercare.co.uk is still showing your website.

It’s possible that Google just stumbled upon that link as it’s not uncommon for someone to make a typo, especially with typing www. Removing that wildcard DNS entry will stop your website being shown on unrelated subdomains like abc.tarka....co.uk, def.tarka....co.uk, etc.

Before removing the wildcard DNS entry, make sure that all needed DNS entries are added.

3 Likes

Thanks arunesh90 for that. Yes that makes sense now. In fact I can enter {anyting}.tarkacomputercare.co.uk and it will take me to my website.

This is how my DNS record was originally setup many years ago by my hosting provider. Is it wrong to have this setup in this way then? Or… is it a case that one just lives with the odd page indexed that has a prefix that was not intended?

I have looked on my Google console and I can’t see that w.tarka***** is specifically indexed. It is not referenced anywhere on my pages (now) but who knows if I made a type at some point in the past and it got indexed by mistake.

I assume that if it is not referenced anywhere anymore then the entry will eventually fall of the index? Is this correct?

I am reluctant to remove the * entry in DNS in case it breaks something else as I am a bit of a novice with this and only copied the complete DNS entry from my hosting partnet to Cloudflare when setting up cloudflare.

It doesn’t necessarily need to be referenced on your own website. Google collects links to crawl and index from various sources, including other websites and your own.

Got it. Thanks.

I wonder why my hosting company would have setup the * record in the first place? It was a time before https:// was common and “needed”.

The easiest way to make Google de-index this URL is to create a permanent 301 redirect from that URL to the intended URL. You can do that with a Page Rule:

http://w.example.com/some-page.html
Forwarding URL
301 - Permanent Redirect
https://www.example.com/some-page.html

Also, make sure the wrong page is not found on your site’s sitemap.

Thanks floripare. I am just checking with my hosting company about the removal of the * record in my DNS too. If I get rid of that then I just want to check with them that it will not break anyting from their side.

1 Like

Actually, I forgot to mention that for the Page Rule to work the wildcard DNS record should be proxied by Cloudflare. Otherwise all requests are actually being sent straight to your server, and you’d need to implement the redirect at your origin (.htaccess or equivalent config file) for it to work.

Bur of course if you remove the wildcard record the subdomain w. will stop responding, and this should take care of it.

Just removed the * record. I will wait to hear back from my hosting company and can always add it back or make other changes they suggest (instead of the * wildcard entry). They put it there so I want to hear from them as to why they di that (all those years ago).

for now.

many thanks to all.

Paul

2 Likes

I don’t expect your hosting company will influence your need for the wildcard entry. You’re in the best position to determine if it breaks anything. It probably won’t.

2 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.