NXDomain - Domain does not exist


#1

So I tried opening a ticket with your support people (ref# 1507577) which has turned out to be quite a waste of time as they don’t respond in a timely manner. This topic below was opened on the 13th and still no resolution so I am hoping someone else has a solution or at least a workaround for us.

We are trying to send emails to vt.edu and they are all bouncing back with domain does not exist. It works everywhere else. They are saying that if they query AAAA records it comes back as domain does not exit.

Here is there response. They said there is an issue on cloudflare’s side. Can someone look into it and let me know.

"The correct response for a AAAA query when the domain has no AAAA records is NOERROR and a blank answer, not NXDOMAIN. NXDOMAIN indicates that the domain doesn’t exist and no other queries should be performed because they too will be empty.

And once we’ve gotten the NXDOMAIN response, the A and MX queries will also return NXDOMAIN until the cache ages out."

Cloudflare support has already acknowledged there is a problem on their end with their code but have only said it will be fixed in the next release which I have no idea when that will be nor will they tell me. It’s very frustrating to get this level of support.

Our email works everywhere else but vt.edu and we are now experiencing issues with wellsfargo.com emailing us. Hopefully I can get a response otherwise we will be moving to another dns provider.

Any help would be appreciated. Thank you.


#2

Well since I’m the same guy working on your support ticket, I guess I can update here. The change is currently running in our staging environment for testing and validation. If all goes well we hope to have it released to production on Wednesday.

I apologize for the delay. If your zone would support it, you may be able to workaround the issue by :orange: your root domain as well, if you have IPv6 enabled.


#3

You wrote: " If your zone would support it, you may be able to workaround the issue by :orange: your root domain as well, if you have IPv6 enabled."

How would I know if my zone will support :orange cloud: ??? I have checked our website which does not have ipv6 addresses, but we use google apps for our email which supports ipv6.


#4

Cloudflare automatically assigns IPv6 addresses to records which are proxied through Cloudflare At the moment it doesn’t appear your domain is using Cloudflare for proxying, just for DNS. If you can proxy your root domain through Cloudflare by making the root record :orange: then an IPv6 address would be assigned as well thus negating the source of the DNS error. The traffic would then be translated to the IPv4 address of your host and proxied to it.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.