NSPOSIXErrorDomain:100 error on safari

Im running Ubuntu 18.4 apache 2 and implemented cloudflares SSL and installed the Privatekey and Cert key etc.

All is working well on ALL browsers except Safari iphone and Imac where is gives NSPOSIXErrorDomain:100 error.

Reading up on it it appears there is a header h2 issue and the current fix is to add “Header unset Upgrade” in the /etc/host.conf file.

This has not worked. Does know what I need to do to fix this issue? its the only browser that dont work with this ssl.

my virtual host is like this:
<VirtualHost *:443>
Protocols h2 http:/1.1
ServerAdmin [email protected]
DocumentRoot /var/www/myfolder/public
ServerName mysite.com
ServerAlias mysite.com

 SSLEngine on
  SSLCertificateFile /etc/ssl/certs/cloudflare_mysite.com.pem
  SSLCertificateKeyFile /etc/ssl/private/cloudflare_mysite.com.pem
  SSLCACertificateFile /etc/ssl/certs/origin-pull-ca.pem
  SSLVerifyClient require
  SSLVerifyDepth 1

 <Directory /var/www/myfolder/>
      Options FollowSymlinks
      AllowOverride All
      Require all granted
 </Directory>

 ErrorLog ${APACHE_LOG_DIR}/error.log
 CustomLog ${APACHE_LOG_DIR}/access.log combined

 <Directory /var/www/myfolder/>
        RewriteEngine on
        RewriteBase /
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^(.*) index.php [PT,L]
</Directory>

Any help would be greatly appreciated :wink:

I found the issue

Remove the : from the virtual host file from this HTTP:// 1.1 to HTTP// 1.1

Hope this helps others :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.