NS Records not propagating?

I’m having an issue with my domain.
I’ve added correct NS and A records, but the NS record is not getting propagated at all.

My config is:
domain.x A my.website.ip
www A my.website.ip
ns1 A my.website.ip
update NS ns1.my.website.ip

Usually that worked and around minutes it was fully propagated, why it doesn’t now?

That’s a Bit Confusing

Can you please Share the Domain ?

I’d Appreciate if you Send a Screenshot Hiding the IP Address

If the domain name is registered at Cloudflare Registrar, unfortunately, currently you cannot change the nameservers if you use Cloudflare as a domain registrar. Currently, Cloudflare Registrar only lets you use Cloudflare name servers.

1 Like

Sure!
The domain is h3g.lt

This my config:

1 Like

A little note.

Nope, i registered the domain with another service and used Cloudflare’s Nameservers.

Usually that was working with all my domains i manage for work, but this time is not.

As you can see here it’s not working:

1 Like

So do you want to create a Subdomain ?

1 Like

yeah, but this way it always worked, i don’t understand why it’s not at the moment.

You need to add update in the Name and Ip Address in the Content .

If you add h3g.it in name its points to h3g.it.h3g.it

If you need update.h3g.it

So add update in the name and Ip address in the Content

Try this and revert back

1 Like

Sorry but what’s the difference from my config?
Maybe i misunderstood your explaination.

Can you elaborate more? It’s early morning and I’m not fully “brainly” active :laughing:

1 Like

What subdomain you need add it in Name , Not the website name

1 Like

that’s what i’ve already did.

update.h3g.lt, is the future subdomain.

if i put fully, it translates to update only in Name part.

The thing i’m not getting is why it’s not propagating at all.

1 Like

You need to add a A Record not a Nameserver

You are Adding a Nameserver Record which was identified the screenshot you shared

Like this shown in the picture

Did your host told to Add a Nameserver Record ?

It looks good from here, but your new name server is not responding to DNS requests at all.

https://dnsviz.net/d/update.h3g.lt/dnssec/

But it looks like you are making changes now, so difficult to see in a consistent state.

2 Likes

Yeah sorry about that

i’m trying to understan if the issue is with me or CF.

If I try to do a nslookup on such hostname, update one, it never resolves :confused:

1 Like

I already done that, but i was asked to do it in this way.

NS1 with an A record to my server IP,
then use an NS record called update to point to ns1.h3g.lt

1 Like

Oh , But why ? Generally in most web-host providers tell to add A Record only ,

How is your web-host provider ?

1 Like

I have no idea, they just told me.
I think is to make some NS lookups to work?
But the issue here is that it’s not propagating and i wonder why.
I mean, i’ve already done similar setups on Cloudflare and they worked, this time no.

I think my config is correct, even if it was enough to use an A Record.

1 Like

Any setup i’m trying with NS records, just breaks

Is it possible for CF to check their NS thing from DNS ?

A, AAAA, CNAME work, but not the NS one.

1 Like

No , Once you have Connected it to Cloudflare you cant the Nameserver’s

I’m having same issues

seems DNS options/managing is kinda broken somehow?

I mean, seems NS records are broken.

Once you have Connected it to Cloudflare you cant the Nameserver’s