NS Records are not propagating

Recently transferred the domain to cloudflare registrar and all was working fine.
Yesterday, we kept seeing Error 525 and tried to solve it but it was not being solved.
So we decided to remove the domain from cloudflare and add it again to have default setting again on domain to fix error 525. ( Please note, here removing doesn’t mean removing from cloudflare as registrar as it has 60 days lock and we don’t want to remove it either from cloudflare as registrar )

We asked our hosting provider to fix the issue and they said as all DNS records are deleted because we removed and added the domain again in cloudflare, we should simply point domain back to hosting provider using their nameservers to set all records and bring the site alive.

So we added 4 NS records in cloudflare for our domain.
Dns1.hostingprovidername.com, Dns2, Dns3 and Dns4 same way.

It has been more than 24 hours since we added NS records but domain is still offline and showing error " DNS_PROBE_FINISHED_NXDOMAIN ".

Can anyone from cloudflare team help please?

That won’t transfer DNS back to your host, as Cloudflare is the NS for your domain. You need to add your DNS records here. If your host can export them as a BIND file, you can import them here.