Notepad++ FTP

I’m using Notepad++ as my FTP. (Bluehost is my provider) After installing Cloudflare I was originally unable to connect to my website. I did learn to change my hostname to my IP address. I was then able to connect.
I am still unable to upload (save) files to my site through Notepad++. Once I try to upload/save the file to my website I am disconnected. How do I fix this?

You will need to ensure you are uploading to a hostname that is set to “DNS only” and not proxied - Cloudflare only proxies HTTP, not FTP or SSH. You could create a subdomain such as ftp to do this separately from your website hostname.

1 Like

Thanks for the info, but how do I create a subdomain such as ftp to do this separately from my website hostname.
(I’ve been on Cloudflare less than 24 hours)

Go to the DNS in your dashboard for your domain by clicking here…
https://dash.cloudflare.com/?to=/:account/:zone/dns
…press “Add Record”, complete the information and press “save”. Make sure to switch the “Proxy status” to off (grey instead of orange).

2 Likes

I’m sorry. I’m pretty literal. I do not see a “Add Record” button or link to push. (I see an “Add a Site” button. I also looked on the panel on the left and could not find the “Add Record” button or link you’re referring to.

I found it under DNS Records. When I try to enter the information this is the error message I get. (I turned off the orange cloud (proxy status) for the one with the same name but I am still disconnected when trying to upload to my website)
A CNAME record with that host already exists. For more details, refer to https://developers.cloudflare.com/dns/manage-dns-records/troubleshooting/records-with-same-name/. (Code: 81054)

Delete the existing ftp record and set up as I showed, using the IP address of your server.

I did exactly what you suggested and I am still disconnected when trying to upload a file.

Confirm what your client is connecting to. Cloudflare doesn’t proxy FTP. Whatever your client is configured to be connected to need to be :grey: or use the origin IP.

2 Likes

I used Google Translate and ChatGPT and I still can’t figure out what you’re saying.
All jokes aside, I don’t know what you mean by “client is connecting to. Cloudflare doesn’t proxy FTP”. I think client = Bluehost, that is my hosting provider. Doesn’t proxy FTP I have no idea what that means.

FTP is a client / server protocol. You have a server (Bluehost) which is listening for FTP connections. In this case Notepad++ is acting as a client to communicate with the server.

In addition to being a DNS provider, Cloudflare provides a number of services for hosts which are proxied (:orange: ) including CDN caching, security, web application firewall, SSL termination).

When a host is proxied :orange: Cloudflare only allows certain ports to connect. FTP ports are not among them. Network ports · Cloudflare Fundamentals docs

As @sjr has said you need to be connected to a host name that is not proxied in your client Notepad++ in your DNS settings. Manage DNS records · Cloudflare DNS docs And the client needs to be configured to point to that record. https://www.csudh.edu/Assets/csudh-sites/webmaster/docs/ftp-clients/usenotepadplus.pdf

2 Likes

Ok, thanks for trying to help me. I think I understood about 70% of what you said.
I was thinking that in the history of Cloudflare I can’t be the only one ever to have the combination of: Bluehost, Notepad++ and Cloudflare.
I was really hoping for a step by step process. For example:

  1. Go to Cloudflare desktop and click on ?
  2. Click on ??? and enter ???
  3. Go to Notepad++ and click on ???
  4. etc.
  5. etc.
    Maybe someone will have the steps.
    I thought I followed @sjr directions exactly but am still being disconnected.
    I will continue to read the information sent to me and continue to attempt to be able to update my website. (24 hour of Cloudflare and unable to update my site, the learning curve seems high)
    Thanks again.
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.