Not working cron tasks

Hello!
After connecting Cloudflare I have one problem - cron tasks don’t work. Why? Help please.
In console I see that requests on the site are being sent successfully. .

Connecting to bigpay.eu (site.eu)|2606:4700:30::681f:505b|:443… connected.
GnuTLS: A TLS fatal alert has been received.
Unable to establish SSL connection.

Do these cron jobs run on the same machine as your server and send requests to the public URL?

If that is the case you should really refactor your code to be non dependent on HTTP calls in the first place. As a temporary workaround you could switch the URL to “localhost” or whitelist your IP, but that should be temporary until you removed the HTTP depenencies from these jobs.

Yes. cron jobs run on the same machine (same IP) as server. I don’t understand where can I add IP-adress on whitelist in Cloudflaere and why can not be left on a permanent basis?

Because it simply is bad system design to rely on a (public) HTTP call for a system-internal call.

Either change the host to “localhost” or whitelist the IP, but again that should be temporary.

If I right understand, add IP the machine where web-site? where can I do this? Section “Firewall”?
And simple add IP and that is all? Command do not need to write?

Yes, that would be an access rule under the Firewall section, which whitelists your IP.

But again, I cant stress enough that this should be temporary. Sorry for insisting on that, but I cant recommend that as long-term solution with a clean conscious.

again problem with SSL connection :frowning:

|2606:4700:30::681f:515b|:443… connected.
GnuTLS: A TLS fatal alert has been received.
Unable to establish SSL connection.

In that case it is not the security layer which blocks the connection, but presumably your SSL settings. Either lower your SSL version in the Cloudflare control panel or upgrade the SSL library on your machine so that it is compatible with whatever version is required by Cloudflare.

:frowning:

Connecting to site.eu (site.eu)|2606:4700:30::681f:515b|:443… connected.
GnuTLS: A TLS fatal alert has been received.
Unable to establish SSL connection.

Thats something you need to fix on your server.

As I mentioned earlier, you could also try to switch to “localhost” but there is no guarantee that would work either. Refactoring that code/changing the approach is still the best approach :slight_smile:

Alternatively you can also create an additional unproxied record (:grey:) and point your cron job towards it but that could reveal your IP address.

How can I do this? Where I can add URL? In “Firewall” on Cloudflare site?

Maybe you can you tell me exactly what need fix on server?

You create an additional DNS record with a different name and do not proxy it, then you change the URL in your cron job to that host.

What I am not so prescribe? Tried and without “@”, only URL and IP-adress

You need to create an additional hostname, what you entered is a URL. Pick a name and be done with it.

Again, if you had refactored that approach it would be fixed by now and be a proper solution.