Not sure if cloudflare is working on subdomain

wordpress

#1

Hi,

Can anyone confirm if I have my subdomain (staging.) set up correctly on cloudflare. Sorry, this area confuses me a bit.


#2

Hi Mitchell,

Cloudflare is simply managing the DNS on that subdomain. You need to click the cloud to put it on orange (proxy + DNS) if you want all of CF features, speed ups and protections.

In case you need a Page Rule for Dev/Staging environments:

Notice that mitchellfanning.com is not working, there is a redirect loop (using Wordpress? Have you selected Always Use HTTPS?), but staging works albeit not in HTTSP.

PS: I would hide the server IP on here and probably protect a bit the IP (ftp.***.com is too easy to guess and so on).


#3

sorry wrong img.


#4

Forgot also: you should add also a www subdomain (either a CNAME to the root domain or another A entry) and orange-cloud that as well.


#5

Hey matteo

Thanks for the help. This stuff (server, dns, etc.) is a bit over my paygrade :slight_smile:

I was simply trying to shave off a bit of time on overall page load but it seems like this might be a bit of overkill for my needs - specifically on a subdomain considering I’m going to be using staging (staging.mitchellfanning.com) to test updates on an ongoing basis.

Re: redirect loop

Yes, I’m using wordpress (with WP Rocket) but I’ve also got mitchellfanning.com (production) protected by a password which could be one reason why there is a redirect loop occurring (that and the fact that I’m now pointing my DNC to CF, just a guess though).

I’ve made notes based on your comments.

Probably the best option is to just to reset my DNS then push all my updates from staging (staging.mitchellfanning.com) then try to configure cloudflare on the production site (mitchellfanning.com).


#6

Well I do it just for fun (and hobby) at the moment and maybe possibly, in the future, a job :joy:

Well since from what I saw you use the same IP for everything I would put it behind CF just to hide the IP (and maybe add Access on top that is free, if just one user accesses it, to prevent the public from seeing the new content).

I would also hide all the other stuff behind a different hostname (I normally use [kind/service/some-random-name].[city].[nation].[possibly a subdomain].[domain].tld (from this list of short names http://www.unece.org/cefact/locode/service/location.html) or behind Cloudflare (if on Pro Plan there are the WAF rules that are helpful).

The password should be the issue, it could be that you are using a Flexible SSL configuration with an HTTPS redirect on the origin (which is actually hit on HTTP) or a Full (and maybe Strict) SSL config with an HTTP redirect (basically the reverse of the first case). I would try maybe removing any redirect (and the Always use HTTPS option) from CF and trying.

I would probably start with a clean slate (disable basically everything) and then enable as you go along based on needs (if you need help ask away!).

You can simply pause CF and use only the DNS (from the first page of the dashboard) temporarily. Notice that all rules in CF won’t be used, IPs will be yours and no CF SSL will work.


#7

thx @matteo - i may just give it another try today on staging.mf.com…any thx if i have any issues i might bug you a bit more :slight_smile: cheers Mitch


#8

hey @matteo seems to be working now. thanks for your help! :slight_smile:


#9

You are welcome! Remember to set a solution (or at least put down a like) for helpful replies :blush:


#10

This topic was automatically closed after 14 days. New replies are no longer allowed.