Not seeing CF cache status header for my site

Hi guys,

I am not seeing the cf response headers even though i think i have done everything correctly.

cant share the url in this post either

I have the ns pointing at cf. it should be working… Any ideas welcome.

cheers

Just post the domain name like “google DOT com” or similar so that the spam filter doesn’t get it

You’re certain that you have traffic proxied through Cloudflare, as in your DNS entry is orange-clouded and you haven’t paused Cloudflare for the domain?

(post deleted by author)

radio-controlled dot co dot uk

They show for me:

% curl -svo /dev/null https://radio-controlled.co.uk
...
< HTTP/2 200 
< date: Tue, 09 Aug 2022 13:53:37 GMT
< content-type: text/html; charset=UTF-8
< cache-control: s-maxage=31536000, max-age=60
< vary: Accept-Encoding, User-Agent
< x-backend: local
< x-cache: cached
< x-cache-hit: HIT
< x-cacheable: YES
< x-cacheproxy-retries: 0/2
< x-content-type-options: nosniff
< x-fawn-proc-count: 1,6,24
< x-php-version: 8.0
< x-wp-cf-super-cache: cache
< x-wp-cf-super-cache-active: 1
< x-wp-cf-super-cache-cache-control: s-maxage=31536000, max-age=60
< x-wp-cf-super-cache-cookies-bypass: swfpc-feature-not-enabled
< x-xss-protection: 1; mode=block
< strict-transport-security: max-age=31536000; includeSubDomains
< cf-cache-status: MISS
< last-modified: Tue, 09 Aug 2022 13:53:37 GMT
< expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
< report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=b8xNhRttU1HHptAet7Dh46LoPY0QIz9gXtZY3%2BBUJgOAPPYe4VmNFLuVNZuS%2BCa%2BtDFwOQx884r5cZ2sswLNjGot1%2BOeVxTN5qOEqzCwSfXofEgjqqt9pez5paBnTe996XB6vkxuy5nMGqOBI%2BHMjvSP%2B%2BBh"}],"group":"cf-nel","max_age":604800}
< nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
< server: cloudflare

Thanks for the reply.

Yeah just now I put the A record to proxied and the site stopped loading…

Looking at one of the images i see its not cached.

I get x-cache-hit=hit but nothing from CF

If it’s DNS Only, then it’s not going through Cloudflare, and you won’t see any Cloudflare headers.

ok thanks… so when I set it to proxy I get the header as you have shown. (you tested is as I was trying it out. :slight_smile: )

The challenge I have now is that all my JS and images are not loading correctly. Any idea why that would be the case?

thanks. I added it back so its now proxied… but now I have a load of failures in loading images and JS…

404, 410 in some cases. Any idea why this might happen?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.