"Not Secure Connection" error with free ssl certificate

I’ve added a website to my Cloudflare account.
I’ve managed to add the SSL certificate on my webserver (apache2 on Ubuntu) by following this tutorial : https://devanswers.co/configure-cloudflare-origin-ca-apache/.

Every single step on this tutorial worked fine without any error.

The problem is that when i’m visiting the website, my browser is saying that it’s an unsecure connexion (see screenshot (1) below).

I’ve tryed to reload, restart apache. Go under dev mode, disable cloudflare.
I’ve no idea on what to do now. I’ve checked many topics, noone solved the issue.

Note : It seems the certificate has been succesfully installed on the server, but not sure (wanted to add a screenshot (2) but i’m limited to one only)

(1) :

(2) : NA

I’ll realy appreciate any single person who tries to fix that issue.
Thanks you so much.

It looks good to me. Your local DNS probably hasn’t updated and you’re connecting directly to the origin web server, and not through Cloudflare.

WOW ! oh god … I was so stressfull.
Thanks !
Just asked a friend, looks good to him aswell.
Do you know how i can change that on my local computer then ?
I’m so relieved !

This topic was automatically closed after 30 days. New replies are no longer allowed.