Not redirected to HTTPS

#1

I have turn on the Always Use HTTPS setting but it seems that it still redirect to HTTP.

0 Likes

#2

@hanisirfan.work i’ve also struggled, albeit in a different sense since migrating from Google Domains to Cloudflare. I’m using a Let’s Encrypt free SSL certificate on my basic, self-hosted website and had no issues prior to moving, but since then I’ve struggled to find the appropriate SSL Settings. I’ve been through all three of the options available, from Flexible, to Full, to Full (strict), but all return the same type of redirect error.

When I’m not getting stuck behind Cloudflare’s CDN, SSL Labs gave me an A for the setup. I don’t get it. Sorry I’m unable to assist right now, what type of OS are you using for your web server? Have you set up a 301 Redirect to push all unencrypted HTTP traffic on port 80 to HTTPS (port: 443) by default? That can be achieved in a couple of different ways, but never really had any struggles getting that set up.

Please let me know if there’s anything I can do to try and assist. I’m far from an expert, but I’ve managed to spin up a WAMP server recently on CentOS after not touching anything RedHat related since roughly ~2001, however I find myself to be much more comfortable in the Debian family of Linux server distros, but have been doing some initial testing Windows Server 2019, as well – haven’t gotten to setting up an IIS server just yet, was trying to tinker with some simple domain controllers to start, however I’ve been quite happy with my router performing DHCP since enabling dnsmasq which has allowed me to use fast and simple name resolution for my little SoHo intranet type situation, using lab.my-domain.com and it’s been working wonderfully. Not quite certain I want to over-complicate things for what little I use this for, however it’d be pertinent for me to get more familiar with the new Windows Server.

Good luck with your situation, sir.

0 Likes

#3

It works for me. I suspect it’s whatever that Ministry of Education filter is you have displayed causing your issue. Here’s the redirect as I see it in Australia:

[email protected]:~# curl -v http://www.hanisirfan.xyz
* Rebuilt URL to: http://www.hanisirfan.xyz/
*   Trying 104.24.112.106...
* TCP_NODELAY set
* Connected to www.hanisirfan.xyz (104.24.112.106) port 80 (#0)
> GET / HTTP/1.1
> Host: www.hanisirfan.xyz
> User-Agent: curl/7.52.1
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
< Date: Thu, 11 Apr 2019 05:16:43 GMT
< Transfer-Encoding: chunked
< Connection: keep-alive
< Cache-Control: max-age=3600
< Expires: Thu, 11 Apr 2019 06:16:43 GMT
< Location: https://www.hanisirfan.xyz/
< Server: cloudflare
< CF-RAY: 4c5a7d72aa39aee7-KIX
<
* Curl_http_done: called premature == 0
* Connection #0 to host www.hanisirfan.xyz left intact

That’s a perfect http->https redirect. Also works on the blog page, https://www.hanisirfan.xyz/main/ too.

0 Likes

#4

When checking your site just now, I was able to see the Cloudflare SSL cert having been applied to your site, with the content displayed as:

Main page is under development :> BLOGGGG!!!

And here is how the cert appears from my perspective. What SSL Settings have you configured?

0 Likes

#5

Standing up the Cloudflare CDN in front of your website has also given you fairly decent scores, according to SSL Labs website test:

0 Likes

#6

Agreed. I’m seeing the same type of behavior, looks great from all perspectives here:

[email protected]:~$ curl -v http://www.hanisirfan.xyz
* Rebuilt URL to: http://www.hanisirfan.xyz/
*   Trying 104.24.112.106...
* TCP_NODELAY set
* Connected to www.hanisirfan.xyz (104.24.112.106) port 80 (#0)
> GET / HTTP/1.1
> Host: www.hanisirfan.xyz
> User-Agent: curl/7.58.0
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
< Date: Thu, 11 Apr 2019 05:24:10 GMT
< Transfer-Encoding: chunked
< Connection: keep-alive
< Cache-Control: max-age=3600
< Expires: Thu, 11 Apr 2019 06:24:10 GMT
< Location: https://www.hanisirfan.xyz/
< Server: cloudflare
< CF-RAY: 4c5a885f6e935a80-BOS
<
* Connection #0 to host www.hanisirfan.xyz left intact

Not really sure what else you could, or would want to be doing differently.

0 Likes