Not receiving emails into my fasthosts webmail account

Hi, I’m hoping someone can help.
I have a Kajabi site hosted via Cloudflare. However my email is hosted with Fasthosts webmail.
I can send emails via both Kajabi and webmail but I’m not receiving any into the webmail account.
Fasthosts gave me some DNS records to add and I went through all the DNS records with a Kajabi specialist yesterday but still I’m not receiving emails into the webmail account. Please can someone help.
Here are screenshots of my DNS records:

This is a screenshot of the email I received that bounced back:

1 Like

Well, that is certainly a mess.

Can you scroll a bit further down and also show a screenshot of the “Cloudflare Nameservers” section?

lol Yeah, I thought there were too many records

I’ve added these into Fasthosts

I’m afraid there’s too many problems to quickly solve from my mobile phone. If noone else has answered you by then, I could help you when I get back home later.

OK, great. I’ve been dealing with this issue since Monday, or another few hours won’t make a different lol

Many thanks Laudian and I look foward to hearing from later :pray:

Your MX record points to a hostname of mailserver, but you have no such hostname.

I reccomend this Community Tutorial.

Ok, I’m back.

First of all, as pointed out, your MX record points to a non-existing hostname. I just assume the value from your x-named MX record is the correct one?
And you probably (I can’t be sure) don’t need the x record after that.

Then you have two SPF records for, which is not allowed. I’m not really sure what the 2nd record (with the ip4: part) is for.
The one with livemail is for fasthosts.
If you actually need the record with the ip4: part, you need to combine the two SPF records. Otherwise delete that record.

It seems Kajabi is sending mails from, thus an SPF record for the name kjbm. That is ok.

Then, you also have multiple mail-related DNS records proxied, all within the same 213.171… IP-range as that unknown SPF record. The names are mail and smtp. Again, if you need these, they have to be DNS-only, otherwise delete them.

1 Like

The thing is, you have named 2 email services that you are using, but you have records for 3 email services, and the SPF record for that 3rd service is conflicting with fasthosts.

I don’t know what the 3rd service is for, so I cannot tell you to just delete them. Maybe they are there for a reason.
If you don’t use it, delete the records, but maybe make copies of them in a text file before you do so. This is about all the records that have 213.171… in them.

Also, the MX record for one of the other 2 services, the one that has as its target, is definitely incorrect. I don’t know the correct value with any certainty, but you probably want to use the value from the record right below it (

Do you mean the MX records that point to the Do I delete it/them?
The x-named record Fasthosts gave to me, so I’m assuming that is the correct one. I don’t understand what you mean by the ‘x record after that’

OK, shall I delete the SPF - ip4 record?

the DNS mail and smtp, do I keep them, or delete them? Or do I change the setting to DNS only?

You are speaking to a total non-techy person here, so frankly I have no clue what I’m doing. I’ve just been going by what various people have been telling me: Kajabi and Fasthosts and no one seems to actually resolve the issue. So, if you are the techy genius, please bear in mind you’re talking to a beginner lol

I am so appreciative of your help. I’ve been trying to get this rectified since Monday and since then, I haven’t been receiving any business emails into my webmail account. They are sending OK through Kajabi, but I’m not receiving any.

I know it’s a big ask, but would you be able to mark on the screenshots I shared, which records I should change or delete, or add? Would that be possible?

OK, I think I’ve understood what you’ve said. So, here are the updated records:


Looks good so far. Is it working?

Yes!! Yippee, the notification came into the webmail account. Thank you so much!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.