Not quite sure what is happening

1 - About 20hrs ago i registered a new domain. Right away i changed the nameserver to CF. For few hrs the site wan’t working giving error from hosting company. I contacted them and they advised to change back to same hosting company nameserver/pointing, and the site worked in seconds.
Few minutes earlier i tried to change nameserver from hosting to CF but again changing the nameserver/pointing to CF gave the same error. So i thought to change back again to hosting, and it worked again. What is happening to CF nameserver. I’ve never experienced anything similar with previous sites pointing to CF.

2 - I tried to open CF in chrome by simply typing The site won’t open, but when typing just Cloudflare and select from browser it opens. I tried this from this link ( by removed the (community.) and hit enter, guess what…? Nothing. I tried to follow the same steps for a different site. It worked as it was suppose to. This is strange. Again, I’ve never experienced anything like this before. Is CF facing issues?

3 - when registered my new site with CF on the dns page registration doesn’t show right. Look at the image link ( Towards the end of the page it says ( Cloudflare Nameservers. To use Cloudflare, you need to change your domain’s authoritative DNS servers, which are also referred to as nameservers.) But this takes me back to issue - 1 - above.

4 - Maybe not on the topic. Does Argo increase the speed for types of devises, or which type of devise effects best? Is there anyway to check or test before buying it?

Many thanks,

  1. What was the error?

  2. Probably a client issue. Check from another box/browser

  3. You need to set your DNS servers to the ones provided to you by Cloudflare (the pair i.e. and

  4. Argo increase the speed of your website regardless of type of device browsing your website.

When i use CF nameservers site does’t load showing like hosting’s fault. But when i change nameservers given from the hosting company the site works fine. It loads ok. This happened about 12hrs ago and again 1 hr earlier. Now i am using hosting’s nameservers.

edited: just now (10 min after the above message) i tried to reload the page and this error appeared ( But nameservers aren’t pointing to CF

If you change them back and forth, they can take a while to propagate.

Sounds to me like your host may be rate limiting it blocking Cloudflare IPs, can you ask them to whitelist all Cloudflare’s IPs?

Alternative issues at Community Tip - Fixing Error 522: Connection timed out

1 Like

Hi community

Few days ago i mentioned this problem…

CF Nameservers aren’t working. This happened with a domain i registered 2-3 day ago and again with another domain i registered less than 24 hrs ago. The moment i replace the CF nameservers with the hosting company everything works like a charm. This has happened twice in the last few days.

Many thanks,

Lets keep this to one thread.

Whats the domain to begin with?

The domain in your screenshots is not registered in the first place.

that domain in not the subject, however it faced the same issue. The domain i’m facing same issues is

At the moment i’m using the hosting nameservers to continue working with my project.

If i change the actual nameservers ( from my hosting company) to CF, i guaranty you it won’t work, because i faced the same difficulty with


It is difficult to debug if your domain is not on Cloudflare. Also, was it ever properly configured? Cloudflare does not have any A records for that domain.

I am afraid you’ll need to configure the domain on Cloudflare first before anything can be said about it.

ok. i will make the changes so we can check the issues together. it will take 1-2 min


is done

It is on Cloudflare but there are still no DNS records.

that is the problem

Without DNS records it cant work in the first place as there is nothing to resolve. You first need to fix that, then we can look at possible other issues.

with the other projects is used to populate auto now i see empty records

Typically it is automatically set up, but that also depends on the original DNS settings. Right now you need to fix that first.

how? is there anything i can read?

would it be better to set everything from scratch, by deleting this site and start all fresh?

Possibly. Just make sure it really imports everything and that your original nameservers do return the necessary records as well. If they dont the import wont work again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.