Not in the Trusted Root Certification Authorities store

I know I’m really close to getting this all set up. This was working a couple of days ago until I used a caching plugin. I have a origin certificate from cloudflare and the universal is turned on. My simple SSL app says everything is working properly.

The problem is that the site is still not secure and the error on the certificate is:

“This CA Root certificate is not trusted. To enable trust, install this certificate in the trusted root certification Authorities store.”

Where do I enable this trust? Also, I noticed that the certificate in the warning shows that it expired in 2019… However, my certs from Cloudflare are 2021+…

UPDATE
Installed new origin cert and it solved the problem.

I’m not seeing that. Maybe you’re bypassing Cloudflare when browsing from your desktop.

It also passes a global test with https:
https://www.fastorslow.com/app/profile/c68745d8-e805-592c-8b52-3196b8292ba3

Are you using any antivirus software or firewalls on your computer?

Yes works fine on my end too. https://www.cloudflare.com/diagnostic-center/?url=772implant.com

What operating system are you on? Did you modify your hostfile? If you browse directly to the server without going through Cloudflare you will get this issue because Cloudflare’s origin certificate is not part of the common root Store and is not meant to be. It does allow encryption from Cloudflare to the server though.

If it’s not that Can you make sure the time and timezone is correct on you computer and that the computer has the latest updates and certificate root store. Did you try google chrome or Firefox?