'Not fully secure'

UPDATE: I’m thrilled to bits to report that I have secured my site, after an 8-hour non-stop stint. :sunglasses: Here’s what I did:

  1. Went into the URL setting and updated it to https:// as you suggested, @sdayman. This changed the URL within the script (which was otherwise inaccessible due to the software).
  2. Renamed all the specific images I’d used, which my software had defaulted to generic PNGs behind my back.
  3. Deleted the images (part of the site’s basic graphics) that had been flagged up as insecure, as they seemed to be outdated.
  4. Realised my software spontaneously duplicates such images (along with generic, insecure IDs) and deleted these newly-generated images every time I saw them.
  5. Clicked on Properties and made every image I could find Read-Only and Hidden.
  6. Clicked into Personal Data/Privacy settings and removed all personal info from each image (since the software keeps undermining this instruction I keep having the repeat the action).

I only uploaded everything once all these steps had been completed, so I don’t know which ones did the job and/or if any were unnecessary. But I have my shiny green padlocks. :tada:

Thanks everyone for helping me with my query. My software seems pretty niche and I wouldn’t touch it with a bargepole if I didn’t have to, but if these steps I took help anyone else with the same issue, that would be a great thing!

The software, if you’d like to avoid it, is called WebPlus by Serif. Now discontinued, and for good reason. :wink:

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.