Not Found - The requested URL was not found on this server

Hi, I have successfully changed my nameservers for the domain pdoth.de from my hoster strato.de to the two ones from cloudflare. My hoster has accepted these nameservers and cloudflare says my site is active. When trying to access the website, google says “Not Found” and “the requested URL was not found on this server”. I already called my hoster 3 times and while I don’t believe them, they said it was a problem with cloudflare. As it turns out it’s a 4xx client error and the domain can’t be resolved by the nameservers. The guy from the strato support also recommended trying to change the DNS settings via just an A-Record or via IPv6. If someone agrees with him, it would be really nice to hear how to perform these other ways to change the DNS server. Thank you to anyone you can help me, I just have not enough expertise with DNS.

1 Like

Hi @pdoth,

If you changed nameservers to point to Cloudflare, the next step is to make sure Cloudflare points correctly to your origin server (your host).

Please go to Cloudflare Dashboard > DNS tab.

A series of DNS records should be listed. Make sure the record with a type A is pointing to the IP address your host provides.

Hi @floripare loripare,
thank you for the quick answer. I checked my A-Records IPv4 and as it turns it it is the one from my hoster, at least securitytrails.com says so as you can see in the pic. If you have another idea where the problem could be, please let me now. Thank you!

Make sure it is the IP assigned to your website. Some hosting providers will give you different IPs for ftp, mail, http etc.

Also, you should go back and edit the previous msg to remove or re-upload the image with the IP addresses obfuscated. We should avoid making public the IP addresses of our sites, lest some hackers find them and try to attack the site directly, thus bypassing Cloudflare protections.

One thing is clear about your setup. It is working as far as sending requests to your domain to Cloudflare. You an check this by going to your domain with Dev Tools open (Ctrl-Shift-J on Windows for most browsers). On the Network tab you’ll see a header CF-Ray, with the Ray ID assigned by Cloudflare, as well as the header Server: Cloudflare.

So the problem must be somewhere between Cloudflare and your server. I hope others in this Community of volunteers may help you further debug the problem.

@domjh @sdayman @Judge

1 Like

Hi @pdoth,

Can you try pausing Cloudflare on your site and seeing if it then works? This will narrow down where the issue is.

You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions.

1 Like

Thanks so much for your tip, I hope so too!

1 Like

Assuming you have added the IP ending in 86 to Cloudflare, that does not look like the correct IP if your site is running:

Shows a request bypassing Cloudflare directly to your server that returns the 404.

You should probably contact your host to check the IP you should be adding to the A record.

Hi @domjh,
I tried pausing cloudflare on my site, but nothing changed, still a 404 error, because obviously the nameservers from cloudflare are still the active ones for my domain

Yep, as confirmed by the screenshot above, I made a direct request to that IP bypassing Cloudflare and it returned a 404.

I suspect either there is an issue with the site on your host’s end, or the IP you have added to the A record is wrong, they should be able to help with this.

@domjh, thank you so much for your help. I tried to change my A-Record’s IP to the one from cloudflare but when I try to I get the Code 1004 9005 as an error

No problem, you can’t put Cloudflare’s IP as the content for the record. You need the correct IP address for wherever your site is hosted.

However, from quickly looking through previous discussions, it looks like Strato go out of their way to stop users from being able to use external DNS like Cloudflare because they change the IP address of the site very regularly.

You may want to confirm this with them, but it may not be possible to use Cloudflare (easily) while hosting with Strato.

1 Like

The IP address of the STRATO web server is not a fixed IP address but is changed at irregular intervals. The use of Cloudflare is therefore unfortunately not possible in the STRATO Hosting Portfolio

That is really awkward, and I would even consider changing providers to avoid this, but that’s entirely up to you…

1 Like

So my only real oppurtunity is to change my hoster? Do you somehow know if other german hosters like 1&1 (ionos.com) are not being so problematic with cloudflare and CDN?

I believe so.

Not sure, but I have not heard of a problem with using 1&1 with Cloudflare.

Cc @MarkMeyer

1&1 offers their own Cloudlfare integration which seems to work great.

Is it a web package like


(shared hosting)

or a virtual / dedicated host like

?

2 Likes

Hi @MarkMeyer, thank you too for answering, it’s a virtual /dedicated host, not a web package :slight_smile:

Ok. I guess it’s either your Apache / nginx config or your www root has no content. Check the folder, usually /var/www/html

1 Like

I tried to search for www.pdoth.de/var/www/html but the site returned to the 404 error page. Can you explain where I can check the www folder? Thank you so much!

You need to connect via SSH (with PuTTY) or FTP (with WinSCP).
Carefu: since Cloudflare is active, you need to connect directly to your server‘s IP.

There‘s probably a web client somewhere in your Strato dashboard or whatever they provide to administrate the server. That’s far away from Clodflare related services. If you need further help how to connect to your server, you should ask their support or have a look at their FAQ:

Once you‘ve uploaded your web content, we can proceed with our trouble shooting, if needed.

In my strato dashboard I can’t really manage the server, which you can see in the pic below, maybe cause it’s shared hosting (which might be the reason it is not working in the first place). Could you explain what to do after connecting via Filezilla, because you can only manage, delete and upload files, right?