Not Enough Space For IPv6 Adress In Router Configuration

I can’t write the IPv6 address in my router settings. I can only write 15 characters (“2606:4700:4700:”). After that, it doesn’t let me to write more.
The IPv4 works good, but i want the IPv6 too.
What should I do?
Thank you.

Oh and my router is D-Link VDSL (N 600)

I don’t know that exact model, but it seems really strange that there are only 15 characters. Try sending a screenshot.

If there are settings for IPv6 they would probably be in a different area. You can google to see if your router supports IPv6 and where they should be entered for that router type.

15 characters is the max number of characters for an IPv4 address. As others said, your IPv6 setting is probably elsewhere.

hey, thank you everyone.
look like my router needs a reset, because i cant go to the config now.
i will do it and let you know

I cant find it. maybe you can find a guide (DLink N600, DSL6850U)

Do you see an IPv6 section like pictured here?

It might require a firmware update (always uh… fun). You might also check to see if your ISP even provides you with an external IPv6 address . If it doesn’t, having the IPv6 addresses probably won’t help/do anything.

Yes, i see it like the picture.
How can I do firmware update?
On it only shows my IPv4 address

Ok if you see the IPv6 you probably don’t need the firmware update. In the DNS server section in the IPv6 is that the section you’re entering the DNS addresses in?

That website’s IPv6 is down. :neutral_face:

* connect to 2001:4870:a24f:2::90 port 80 failed: No route to host

How about

1 Like

I’m entering it on “use following dns addresses” in the ipv6 section

If it’s not just a UI issue where the characters are added, but can’t be seen I’m afraid you’d have to ask the vendor.