Not being able to log into Plesk

Hello I have a problem when trying to access my Plesk Interface while Cloudflare is active.

I have several Subdomains on my Domain and one of them refers to a Plesk. When trying to open that Subdomain everything seems fine, but after logging in, I am just getting redirected back to the login Page no errors on screen.

I’ve turned on Development Mode via the Cloudflare Dashboard and then it is redirecting me after login in, so i thought to myself it must be the cache. I’ve already tried different approaches such as deactivating Proxy and genearting a custom Page Rule where i define to bypass the cache, but it ain’t working.

I am starting to loose my mind so any help would be highly appreciative.

Few things come to my mind to troubleshoot if you are using a proxied (:orange: cloud) hostname/sub-domain:

  1. Plesk - does it work over HTTPS at the origin host/server?
    1.1. Plesk - over which port does it work?
  2. Cookies - non-www / www or a sub-domain?
  3. Cloudflare SSL settings - Flexible, Full, Full (Strict)?
  4. Cache - maybe trying with Private Window or another Web browser + clearing Web browser cache and cookies?

Page Rules shouldn’t work (apply) if you switched from :orange: to :grey:.
But this one makes me wonder, does it either work when it’s not proxied and you still got the redirection issue when using :grey: (DNS-only) for that particular hostname/sub-domain?

Hey, do you get redirected to [YOUR_DOMAIN]:8443? In older versions it was common to reach the backpanel of Plesk over this port. Unfortunately the Cloudflare-Proxy only supports HTTP(s) over port 80/443 … if that’s your case you could try creating an Argo Tunnel and route some subdomain e.g admin.[YOUR_DOMAIN] to your tunnel :slight_smile:

It actually is supported and compatible with Cloudflare proxy (:orange:) mode.

HTTPS ports supported by Cloudflare:


I am sorrry but I have to correct you at this statement as far as the supported and compatible ports list with Cloudflare proxy mode (:orange: cloud) can be found at the below article:

1 Like

The origin server is a WordPress site which does work over HTTPS.

The plesk is hosted on a subdomain =

It’s set to Full.

I forgot to mention but if I try to access the plesk backend over the network where the server is hosted i am redirected successfully, only when I try to access it externally I am getting the error where I don’t get redirected.

After testing with the DevTools on Chrome i can see that i get a 303 error. I think what is happening is the POST request where i write my login information tries to redirect it back to my IP-adress which isn’t resolveable externally.

Yup still the same issue when using DNS-only for the sub-domain.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.