Not authorized by default to use '[email protected]' in 'mfrom' identity,

Im not super techie so bare with me.

Im getting this error from an email tester program

edferrigan.com: Sender is not authorized by default to use ‘[email protected]’ in ‘mfrom’ identity, however domain is not currently prepared for false failures (mechanism ‘~all’ matched)”

How do I fix this please? My emails are not making it to my customer inboxes. Thanks so much.

Also, I made this change already:

What we retained as your current SPF record is:

v=spf1 include:spf.privateemail.com ~all

It should be changed to:

v=spf1 include:spf.privateemail.com ip4:185.223.74.11 ~all

The Name Server handling the domain name edferrigan.com is charles.ns.cloudflare.com.

But Mail-Tester still gives me an error.


Here are verification details

Verification details:

dig +short TXT edferrigan.com :

  • “ca3-588f4ec219cf482c986d69ff6ebbc526”
  • “facebook-domain-verification=zvds2oxcyeb7x3iv1rc9ojjmbqwmyf”
  • “google-site-verification=RZ0DzU-czP4zWJ71oc6SMC2cVcCcZkTpX4yz-wqHMjk”
  • “default._domainkey IN TXT ("v=DKIM1;k=rsa;p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAwHg4JU3slM9cXCXwcAzIcmztUM8ixo5vfEf7wDGTvvmPZ4STsnc457yq8gYTMSppGOUgKY5Gicd9bzQrGrFAI0AIjI+WgS26aggT5bzByKdVOnYdBxjtVZ2YT0PI9F3yvieQdsT8Esq3ThOcO3j/U9PnD/x+jkK9o9TEgKj” “i8yQD/5zExJMRoFAC2VR9U57qWl0mVTfHTEcw0dqv0tPItm4R48Eyrfd4b4GjBCAUAgXU4c7Udh4esXJvkb6FogN3Zuctcc7WSdU7sBGkAW9aHB6mwM06LI6XfW+2MqYCzUKF09Z/QJ6AU/WrAxTLBiY0TUZOY/2E8cECbctyQ0Ut3wIDAQAB");”
  • “google-site-verification=Tqo4PiU9Mep1BSC2lR0CzmXh-Fv-EQFgTD2QXjP3YtQ”
  • “k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDQSBd+yL5HELD+IdXKYXr5JfuFLYwJ/QSyUSr/jIwWMxxqE2ZtVz66+wWKPEpEVeh3YdDFNjBSrIJTUVaaJhn4qwBatT3FNq23iDGHduqdTSxaGigeZY4KN5Zr/UfCUyuAW0P9mrOfXj0sRppK728ZyS6H5NBn53RLFu89vPe56QIDAQAB”
  • “v=spf1 include:spf.privateemail.com ~all”

dig +short TXT @charles.ns.cloudflare.com. edferrigan.com :

  • “ca3-588f4ec219cf482c986d69ff6ebbc526”
  • “facebook-domain-verification=zvds2oxcyeb7x3iv1rc9ojjmbqwmyf”
  • “google-site-verification=RZ0DzU-czP4zWJ71oc6SMC2cVcCcZkTpX4yz-wqHMjk”
  • “default._domainkey IN TXT ("v=DKIM1;k=rsa;p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAwHg4JU3slM9cXCXwcAzIcmztUM8ixo5vfEf7wDGTvvmPZ4STsnc457yq8gYTMSppGOUgKY5Gicd9bzQrGrFAI0AIjI+WgS26aggT5bzByKdVOnYdBxjtVZ2YT0PI9F3yvieQdsT8Esq3ThOcO3j/U9PnD/x+jkK9o9TEgKj” “i8yQD/5zExJMRoFAC2VR9U57qWl0mVTfHTEcw0dqv0tPItm4R48Eyrfd4b4GjBCAUAgXU4c7Udh4esXJvkb6FogN3Zuctcc7WSdU7sBGkAW9aHB6mwM06LI6XfW+2MqYCzUKF09Z/QJ6AU/WrAxTLBiY0TUZOY/2E8cECbctyQ0Ut3wIDAQAB");”
  • “google-site-verification=Tqo4PiU9Mep1BSC2lR0CzmXh-Fv-EQFgTD2QXjP3YtQ”
  • “k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDQSBd+yL5HELD+IdXKYXr5JfuFLYwJ/QSyUSr/jIwWMxxqE2ZtVz66+wWKPEpEVeh3YdDFNjBSrIJTUVaaJhn4qwBatT3FNq23iDGHduqdTSxaGigeZY4KN5Zr/UfCUyuAW0P9mrOfXj0sRppK728ZyS6H5NBn53RLFu89vPe56QIDAQAB”
  • “v=spf1 include:spf.privateemail.com ~all”

spfquery --scope mfrom --id [email protected] --ip 185.223.74.11 --helo-id 74-11.premium.groovemail.net :

I also use Namecheap’s Privatemail for few domains, however the DKIM value seems a bit odd to me because of the brackets (\ and \") :thinking:

Are you sure you’ve correctly copied the value from the Namecheap’s interface?

"default._domainkey IN TXT (\"v=DKIM1;k=rsa;p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAwHg4JU3slM9cXCXwcAzIcmztUM8ixo5vfEf7wDGTvvmPZ4STsnc457yq8gYTMSppGOUgKY5Gicd9bzQrGrFAI0AIjI+WgS26aggT5bzByKdVOnYdBxjtVZ2YT0PI9F3yvieQdsT8Esq3ThOcO3j/U9PnD/x+jkK9o9TEgKj" "i8yQD/5zExJMRoFAC2VR9U57qWl0mVTfHTEcw0dqv0tPItm4R48Eyrfd4b4GjBCAUAgXU4c7Udh4esXJvkb6FogN3Zuctcc7WSdU7sBGkAW9aHB6mwM06LI6XfW+2MqYCzUKF09Z/QJ6AU/WrAxTLBiY0TUZOY/2E8cECbctyQ0Ut3wIDAQAB\");"

Furthermore, regarding the 2nd DKIM selector, so you’ve got the two here? Okay.

First things first, A mail.edferrigan.com is proxied :orange:. Please, switch this to :grey: (DNS-only).

When you’re using your email client, MS Outlook, Mozilla Thunderbird, etc., which server are you using to sent out email that is causeing you the issue? How did you configured your email client to talk to your MTA? Does it use Privatemail’s credentials and pop/imap/smtp, or rather some other?

Your MX is privatemail.

Adding the DKIM value and the IP from your other server into the TXT (for SPF), without DMARC should work if the TXT (for SPF) would have ?all (neutral).
Can you try with neutral for testing purposes?

ok yes, the first thing I changed is the DKIM to:

v=DKIM1;k=rsa;p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAwHg4JU3slM9cXCXwcAzIcmztUM8ixo5vfEf7wDGTvvmPZ4STsnc457yq8gYTMSppGOUgKY5Gicd9bzQrGrFAI0AIjI+WgS26aggT5bzByKdVOnYdBxjtVZ2YT0PI9F3yvieQdsT8Esq3ThOcO3j/U9PnD/x+jkK9o9TEgKji8yQD/5zExJMRoFAC2VR9U57qWl0mVTfHTEcw0dqv0tPItm4R48Eyrfd4b4GjBCAUAgXU4c7Udh4esXJvkb6FogN3Zuctcc7WSdU7sBGkAW9aHB6mwM06LI6XfW+2MqYCzUKF09Z/QJ6AU/WrAxTLBiY0TUZOY/2E8cECbctyQ0Ut3wIDAQAB
Automatic TTL

Not sure where you are seeing this for me to change it?

Im waiting for my email provider to let me know any SPF settings I need to be aware of.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.