Not able to enable Universal SSL. Code 1006

I am trying to setup up some sites on my domain enstrom.nu

When adding some A records pointing to my IP address I get ERR SSL VERSION OR [CIPHER MISMATCH] errors when using the Cloudflare proxy. When disabling the proxy the site works fine but exposes my private IP.

I try to follow the guide
(Community Tip - Fixing ERR SSL VERSION OR CIPHER MISMATCH in Google Chrome)
I get stuck on step 2. When trying to enable Universal SSL I get Error “SSL has been disabled for this zone (Code: 1006)”


I also don’t have any Edge Certificates for my domain when looking under Edge Certificates.

Things I tried:

  1. Add a proxied A record for *.enstrom.nu
  2. Pause and unpause Cloudflare on site
  3. Set different SSL settings flexible/full/full(strict)
  4. Searched the community but have not found any help.

Now I have also tried to enable via Cloudflare API but keep getting the same errors

curl -X PATCH "https://api.cloudflare.com/client/v4/zones/[my zone ID]/ssl/universal/settings" \
     -H "X-Auth-Email: [my email]" \
     -H "X-Auth-Key: [API-key]" \
     -H "Content-Type: application/json" \
     --data '{"enabled":true}'

{"success":false,"errors":[{"code":1006,"message":"SSL has been disabled for this zone"}],"messages":[],"result":null}

Here’s the result from the GET command

curl -X GET "https://api.cloudflare.com/client/v4/zones/[my zone ID]/ssl/universal/settings" \
     -H "X-Auth-Email: [my email]" \
     -H "X-Auth-Key: [API-key]" \
     -H "Content-Type: application/json"

{"result":{"enabled":false,"certificate_authority":"digicert"},"success":true,"errors":[],"messages":[]}

Anyone have ideas on how to enable universal SSL for my domain? or more info on “code”:1006,“message”:“SSL has been disabled for this zone”?

I’m on the free plan so I can’t open any support tickets :frowning:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.