Normal for cloudfare to erase @ in A record entries?

Have never seen this with DNS records.

Whenever I enter the @ symbol for root (as its even instructed in the CF interface) and then save, it erases that symbol and replaces it with our domain name.

Trying to debug why our site is down, but can’t tell if this system is working or not.

@ is shorthand for the root domain. Does the root domain resolve in DNS when you query it?

Not sure. Just did a DNS lookup and it shows the CF nameservers but there are completely different A records than what appears in our CF account. Would that be for the Proxied setting? (The orange cloud icon.)

Just disabled that Proxied setting. No idea why that’s set as the default. Why would I want to redirect to a totally different IP?

Such a totally confusing interface… :frowning:

Seems like its sorted. Totally don’t get why the default is to change the IP addresses we’ve entered. Really don’t get why Proxied is set as default. Anyway, sorted now.

It is because the Cloudflare proxy features are why most people are using Cloudflare DNS.

I’m glad that you have your DNS working to your expectations now.

When you disable the proxy you are basically disabling all of cloudflares features so it defaults to on because they assume most people want to use all of its features. (Such as WAF, Workers, Cache, etc)

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.