Noindex tag showing up in my page header

There are several pages on my website (not all pages) that have a noindex tag included in the header.

<!DOCTYPE html>
	<html lang="en">
	  <head>
	    <title>https://mysite.org/research/intro-research/</title>
	    <link rel="canonical" href="https://mysite.org/research/intro-research/">
	    <meta name="robots" content="noindex">
	    <meta charset="utf-8">
	    <meta http-equiv="refresh" content="0; url=https://mysite.org/research/intro-research/">
        </head>
	</html>

Where on google:

<!DOCTYPE html>
<html lang="en" dir="ltr" class="scroll-smooth dark" data-default-appearance="dark" data-auto-appearance="true"><head>
  
  
  <meta http-equiv="content-language" content="en" />
  
  <meta name="viewport" content="width=device-width, initial-scale=1.0" />
  <meta http-equiv="X-UA-Compatible" content="ie=edge" />

This tag is not in the source code of these pages and when inspected via Google’s Url inspector it is also not visible, yet Google’s bot is picking up on it enough to prohibit those pages from being indexed. In fact, the only place that displays it is using hugo-decoded.be. Since I host the site, there is no way it could be related to an issue with hosting. The only service that proxies any connection to those pages is cloudflare, so by process of elimination cloudflare appears to be the most viable cause of the header injection. Regardless of whether caching is enabled or disabled this phantom header remains.

I have no idea where it is coming from, yet find myself going in circles attempting to correct it’s existence.

To fix this issue first you can check that which SEO plugin you have to use? Then go to the plugin even you have use Rank Math, Yoast, or All in one SEO. Check out the setting in the plugin that your website, pages, post, category etc has selected no index tag or index tag. If already select the noindex then change it into index.

The Second step is to check our your WordPress setting. Go to WordPress admin panel > Setting > Reading and make sure “Discourage search engines from indexing this site” is uncheck. If this option is checked then uncheck it.

Hope your problem will be solved.
I have facing same issue on my client website https://apkpitch.com/ and now the issue has resolved.

I appreciate the suggestion. My website is not built on WordPress though, and does not use any plugins. I use Hugo to generate my website statically, from markdown files to HTML. From there it is directly uploaded to the live web server on my VPS.

I have just opened up a ticket with my VPS service provider to see if there is any possibilities of the tag being injected by them. It is definitely occurring between the clients request and Cloudflare routing the request to my server. As, the tag does not occur in the source code or on the web server hosting the file.

It would be convenient if I could find someway to trace the source code of the file through this route to see if and or when along the path any changes are being made. Hmm… some food for thought.

Sadly, much to my chagrin, I was mistaken. The phantom flag is still very much present, but is showing up on a different set of pages.

I have contacted my VPS provider, and they assured me that there is nothing on their end that could be causing the flag to appear, and inquired if I have contacted cloudflare regarding the flag injection.

It is not as if this is a first time occurrence of ‘noindex’ flags being injected into cloudflare users pages. There is a whole body of users who have experienced this issue. How they resolve it is still undetermined.

I just had 40 pages rejected from being indexed on Google due to this mysterious phantom ‘noindex’ tag, it has been 8 days since my first post, and except for the appreciated sole response I received due to a misunderstanding, I am not getting anywhere.

My hosting provider has assured me it is nothing on their end, and apparently Cloudflare does not provide any support. So, the only resolution that comes to mind would be to drop cloudflare for all of the sites I host and move to some other dynamic DNS provider.

I have submitted a support ticket as requested by a hosting provider to cloudflare. The response to which was to inform me that my current plan provides support via the community portal, which is here. It has been ten days since I opened this issue, without resolution and only one response.

Along with the redirection to the community forum, it encouraged me to review the cloudflare documentation. Which was done, and appears to be out dated.

The user base needed to resolve problems such as mine either does not exist at this point in time, is not large enough to satisfy demand, or does not incentivize users to respond. Saying as much, all of this does represent a real failure in Cloudflare’s ability to provide ample support for it’s products.

Having the same issue, no solutions yet?