Nodejs can not be proxy correctly

Recently, around 1 weeks ago. There were some wrong with Cloudflare DNS proxy。
The website been working properly for serval months. However, error happens recently.
issue:
When I visit my website, an error shown as below:

<!DOCTYPE html><html><head><meta charSet="utf-8"/><meta name="viewport" content="width=device-width"/><title>404: This page could not be found</title><meta name="next-head-count" content="3"/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-78c92fac7aa8fdd8.js"></script><script src="/_next/static/chunks/webpack-816dd4f2dcd42389.js" defer=""></script><script src="/_next/static/chunks/framework-4498e84bb0ba1830.js" defer=""></script><script src="/_next/static/chunks/main-42643f50d61246ff.js" defer=""></script><script src="/_next/static/chunks/pages/_app-0fe44225c17aa1f2.js" defer=""></script><script src="/_next/static/chunks/pages/_error-a73f64b4ecbfa014.js" defer=""></script><script src="/_next/static/7Vasmhw25HziFz0kOlbVk/_buildManifest.js" defer=""></script><script src="/_next/static/7Vasmhw25HziFz0kOlbVk/_ssgManifest.js" defer=""></script></head><body><div id="__next"><div style="font-family:system-ui,&quot;Segoe UI&quot;,Roboto,Helvetica,Arial,sans-serif,&quot;Apple Color Emoji&quot;,&quot;Segoe UI Emoji&quot;;height:100vh;text-align:center;display:flex;flex-direction:column;align-items:center;justify-content:center"><div style="line-height:48px"><style>body{color:#000;background:#fff;margin:0}.next-error-h1{border-right:1px solid rgba(0,0,0,.3)}@media (prefers-color-scheme:dark){body{color:#fff;background:#000}.next-error-h1{border-right:1px solid rgba(255,255,255,.3)}}</style><h1 class="next-error-h1" style="display:inline-block;margin:0 20px 0 0;padding-right:23px;font-size:24px;font-weight:500;vertical-align:top">404</h1><div style="display:inline-block"><h2 style="font-size:14px;font-weight:400;line-height:28px">This page could not be found<!-- -->.</h2></div></div></div></div><script id="__NEXT_DATA__" type="application/json">{"props":{"pageProps":{"statusCode":404}},"page":"/_error","query":{},"buildId":"7Vasmhw25HziFz0kOlbVk","nextExport":true,"isFallback":false,"gip":true,"scriptLoader":[]}</script></body></html>

this error only happens when I turn on DNS–Proxy

snapshot is:
normally , it will be like this: fi’g on the left.

around 1 week ago:
fig on the right

I tried my backup data of website. Still error happens. and If I switch another website, error still happens.

My assumption:
Cloudflare has made some modification recently, and this movement result in error dispalying of my website.

It would be grateful that anyone can help.
Thanks a million.

Hi @320462212,

Can you use Configurations Rules to turn off Cloudflare features like Minify/Rocket Loader etc, and just have Cloudflare proxy turned on?

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.