Node/Socket Error during WebSocket handshake when activate Cloudflare

#1

Hi, for a few days now i get errors in my console.

WebSocket connection to 'wss://*********.com/socket.io/?EIO=3&transport=websocket&sid=o_APMDct5JQ6Ct2oAGD2' failed: Error during WebSocket handshake: Unexpected response code: 400
WS.doOpen @ socket.io.js:1

I dont know why…

If you deactivate Cloudflare, i dont get that, but than i cannot hide my own IP Address and something.
Is there a way that i only hide my IP Address without any functions of Cloudflare or something?

Or someone can help why i get that Websocket Problems with active Cloudflare?

0 Likes

#3

Is that needed? I dont have Cloudflare activated cause than i get that error in console.

Dont want to post the domain if its okay. I post the error i found… there is nothing more.
Also checked nginx error logs and something, there is nothing.

It is working without cloudflare but with cloudflare it get that error

0 Likes

#5

But for want check? It works now without cloudflare… so activate before testing there…?

0 Likes

#7

Omg, looks like WebSockets was not activated in Network but i dont know why…

I was working for a half year and now had problems. Hope that fixed it… looks like no errors

0 Likes

closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes