No X-Forwarded-For come from proxied DNS reuest

I am using Traefik on GCP, and trying to whitelist IPs based on source IP

the issue is I don’t receive a X-Forwarded-For header in the request comming from CloudFlare

I’m going to say it’s probably there…but if by some chance it’s not, try CF-Connecting-IP

1 Like

well it is not, and i need the X-Forwarded-For to use the white list feature of Traefik …

	"Header": {
	"Accept": ["text/css,*/*;q=0.1"],
	"Accept-Encoding": ["gzip"],
	"Accept-Language": ["en-US,en;q=0.9"],
	"Cdn-Loop": ["cloudflare"],
	"Cf-Connecting-Ip": ["[REDACTED]"],
	"Cf-Ipcountry": ["US"],
	"Cf-Ray": ["[REDACTED]"],
	"Cf-Request-Id": ["[REDACTED]"],
	"Cf-Visitor": ["{"
		scheme ":"
		https "}"
	],
	"Connection": ["Keep-Alive"],
	"Cookie": ["[REDACTED]"],
	"Origin": ["[REDACTED]"],
	"Referer": ["[REDACTED]"],
	"Sec-Ch-Ua": [""
		Not A;Brand ";v="
		99 ", "
		Chromium ";v="
		90 ", "
		Google Chrome ";v="
		90 ""
	],
	"Sec-Ch-Ua-Mobile": ["?0"],
	"Sec-Fetch-Dest": ["style"],
	"Sec-Fetch-Mode": ["cors"],
	"Sec-Fetch-Site": ["same-origin"],
	"User-Agent": ["[REDACTED]"],
	"X-Forwarded-Host": ["[REDACTED]"],
	"X-Forwarded-Port": ["443"],
	"X-Forwarded-Prefix": ["[REDACTED]"],
	"X-Forwarded-Proto": ["https"],
	"X-Forwarded-Server": ["[REDACTED]"],
	"X-Real-Ip": ["[REDACTED]"]
},

reference , check last comment in the PR

Absent any other options, I suggest you contact Support to find out what happened to the x-forwarded-for header.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.